Connection allowed only for logged-in user?

Forums / NoMachine for Linux / Connection allowed only for logged-in user?

Tagged: 

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #432
    Avatarsnoopy
    Participant

    Hi,

    one question to NX4 and Linux: Is it possible to allow a remote connect via NX to a machine only for the currently logged in user?

    Typically the users configure the NX-Server in that way, that anyone can connect without a permission. Thats needed to connect from outside of the company to an computer without giving the permission there by hand. But in this case, anyone, who can connect to that machine get access to the screen the currently logged in user. Ok, his screen should be locked – however, its no a nice solution.

    I found the option to use the nx-DataBase (EnablePasswdDB) – in this case i have to add the users, which allowed to connect by hand. But at runtime i do not know, which user is currently logged in …

    Does any one know a smart solution for that problem? Is there an option for NX4 to open a new session in any case as it was in NX3.5?

    #433
    Avatartitan
    Participant

    I’m not sure I understand correctly.

    Suppose you are User1, logged on X :0. User2 connects to the machine (this User2 is a different system user). Doesn’t NoMachine display a dialog asking User1 (on :0) whether User2 should be able to connect?

    Is there an option for NX4 to open a new session in any case as it was in NX3.5?

    NoMachine Workstation and all Terminal Server products do this. They offer the option to create a new session. Anyway this doesn’t solve the problem of what to do when User2 wants to connect to the desktop of User1. This is a perfectly common case of desktop collaboration.

    At the moment the solution is to let User1 connect without asking permissions (since we assume User1 is the same User1 and asking permissions would block User1 from connecting in the case he moved to a different machine), and force User1 (or any other user currently viewing :0) to authorize User2.

    #450
    Avatarsnoopy
    Participant

    Yes, NX does (normally) ask. However, to work from remote i have configured the NX-Server that it dont ask for permission. Because if it asks, and i sit remote, a cannot click on the button “ok” 😉

    It would be very helpfull to have a list, e.g. in the NX-Database, where permitted users to connect can be stored. The idea is, in this case there are many system users (UsersX), which can connect to a machine (e.g. via active directory). However, there is only one “owner” of the machine (User1), which normally sits in front of the screen (session :0) and in this case he is the only one who should be able to connect via NX to that session. For that i need a kind of a white-list to allow only User1 to connect.

    #453
    Avatartitan
    Participant

    Yes, NX does (normally) ask. However, to work from remote i have configured the NX-Server that it dont ask for permission. Because if it asks, and i sit remote, a cannot click on the button “ok” 😉

    OK, but it will ask only if you connect to the machine as a different user. If you connect to the machine as the same user running the session you should get in without problems.

    Is there any reason you are connecting as a different user (I’m sure there is, just asking to be sure I understand correctly).

    #455
    Avatarsnoopy
    Participant

    Ok – thats the point – Yes, of course there is a reason why i use another user: my standard-account was used for tests with many different NX-versions, especially with some 4betas. Since this time there something wrong with my account – connecting to it i can enter the (right) password, but a connect did not work (error with ssh-authentication and sometimes with the host 127.0.0.1). I have removed ~/.nx, /usr/bin/NX and so on – but no success.

    After a long search i found creating an additional account, it works without problems – just connection to this account and then using the screen of my standard user … so i decided not go deeper in the problem with my account…

    So – then the “problem” is solved – its only a problem of my local account but not of NX … so thank you for the help!

    Stefan

    #462
    Avatartitan
    Participant

    After a long search i found creating an additional account, it works without problems – just connection to this account and then using the screen of my standard user … so i decided not go deeper in the problem with my account…

    Well, let me know if we can help with this first account. Did you try creating a new .nxs file to login with the first user? Can it be a wrong key stored in the .nxs file?

    #467
    Avatarsnoopy
    Participant

    Of course would be interresting to fix this.

    How do i create this .nxs-file? I did not find one in my old and the new user (which works with NX) …

    #512
    AvatarTor
    Contributor

    Hi snoopy.

    The NXS files store the connection settings, and you can find them (by default) in your Documents folder under the NoMachine directory.
    If you can’t find them there (or if you want to change the default location) click on the Change player settings button in the NoMachine GUI and read the field Connections.

    To create a new NXS file you just need to create a new connection: all settings will be set to their default values so we’ll know if your problem is related to a wrong key.

Viewing 8 posts - 1 through 8 (of 8 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.