Connection from Debian amd64 to i386 makes high load on CPU?

Forums / NoMachine for Linux / Connection from Debian amd64 to i386 makes high load on CPU?

This topic contains 3 replies, has 3 voices, and was last updated by Avatar fra81 1 week, 5 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #23120
    Avatar
    mckaygerhard
    Participant

    I setup the i386 remote NoMachine to use OpenGL and 30 FPS on a Debian Jessie and connected from a Debian 10 amd64. When connected,  the i386 machine has a high load.

    #23137
    Avatar
    Britgirl
    Keymaster

    What is the desktop environment you are connecting to? Do you notice if this occurs as soon as you connect, or after you open a specific application? What is the application in that case?

    The output of top would also be useful because it will indicate what process it is which is causing the increased CPU usage.

    On the server side, open a terminal and run the following:

    top -n 1 -b > output.txt

    What’s the output you get?

    #23141
    Avatar
    mckaygerhard
    Participant

    Desktop of the jessie are openbox. Desktop in debian 10 are mate or lxde.

    Occurs as soon as i connect

    Important lines of top as you can see nxbin are almost in top.

    32422 remoto     0 -20  395324 123600  62504 S   15,3  3,1  13:37.09 nxnode.bin
    5043 remoto    20   0  741600 236876  39916 S   6,3  5,9 141:55.71 chromium
    12621 remoto    20   0  109476   5592   1220 S   6,3  0,1   0:02.83 caja
    19509 remoto    20   0 1103380 442008  89616 S   6,3 11,0   1:51.10 palemoon
    19962 remoto    20   0    5132   2708   2332 R   6,3  0,1   0:00.01 top
    1 root      20   0   27744   3660   2656 S   0,0  0,1   0:10.03 systemd

     

    #23213
    Avatar
    fra81
    Moderator

    15% of CPU usage doesn’t seem too much if the screen is updating. Are you using latest NoMachine versions on client and server? Recent versions always ship the H.264 encoder which minimizes CPU usage. Anyway you can check the used codec in the Display settings panel.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.