Connection refused when trying to connect to session started from inittab

Forums / NoMachine for Linux / Connection refused when trying to connect to session started from inittab

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #2487
    majordidge
    Participant

    Hi,

    I can successfully connect to the X11 KDE graphical console on my slackware linux server when I start it using startx after logging into a runlevel 3 (full multiuser with networking) session. However, when I attempt to connect to the same X11 KDE console automatically started in a runlevel 4 (full multiuser with networking and GUI) session i get error 107: connection refused.

    I am using free NX 4 on the Windows 7 client and on the Slackware server.

    Any ideas?

    MD.

    #2509
    Britgirl
    Keymaster

    Slackware is not supported but we will fix it. Check out the TR here: https://www.nomachine.com/TR02L04284

    #2551
    majordidge
    Participant

    Hi Britgirl, thanks for the response.

    I had already included the startup call in my rc.local startup script, hence my ability to connect when I start the X11 session manually. Looking at the logs (copy attached) from the failed attempt to connect to the auto-started session it looks like things start going wrong some way into proceedings:

    528 6136 09:04:59 050.141 ClientSession: Runnable at 0x443f540 caused the session at 0x227e6b0 to fail.
    528 6136 09:04:59 050.141 ClientSession: Failing reason is ‘Could not connect to the server.

    Error is 107: Connection refused’.

    I don’t imagine the issue is too complex and some insight into what “Runnable at 0x443f540 caused the session at 0x227e6b0 to fail” actually means might help in the diagnosis.

    Thanks.

    MD.

    Attachments:
Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.