Connection reset by peer

Forums / NoMachine for Linux / Connection reset by peer

  • This topic has 6 replies, 3 voices, and was last updated 2 months ago by AvatarMth.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #31252
    Avatarbutsuriboy
    Participant

    Linux Mint Cinnamon 20.1 host, Windows 10 Pro build 19042.685 (version 20H2) client.

    Server/ Client NoMachine Version: 7.0.211

    Attempting to connect to the Linux machine using the Windows client (new connection as I recently installed Linux mint to dual boot), when I try to connect (enter username/ password), I get a flash of the connections page, then it immediately reverts to the message:

    Attempting to reconnect to <machine-name>

    Error was: Connection reset by peer

    On the Linux (server) side, I keep seeing a popup saying “User <username> disconnected” and “User <username> connected”.  This seems to continue indefinitely until I just quit the Windows client.  I’ve attached the server logs — any help much appreciated!

    Attachments:
    #31293
    AvatarBritgirl
    Keymaster

    The logs would need to include debug level. We checked on the fly and didn’t have any problems installing and running sessions from a Linux Cinnamon 20. If this is your first installation, I suggest to completely uninstall, remove all nx dirs

    rm -rf /usr/NX .nx

    and install again. If that doesn’t help, submit the logs of a failed session once you have enabled debug on the server side and gathered the logs. See this article for instructions: https://www.nomachine.com/DT11R00182. Send them to forum[at]nomachine[dot]com making sure to reference the title of your topic. Thanks!

    #31297
    Avatarbutsuriboy
    Participant

    Just sent the logs as requested via email.  Thanks for your help!

    #31433
    AvatarBritgirl
    Keymaster

    We received them but they didn’t reveal anything out-of-the-ordinary. Can you send us the nxdb file?

    – reproduce problem
    – shutdown NoMachine if possible
    – copy nxdb file and send to us directly to forum[at]nomachine[dot]com

    if shutdown is not possible

    – reproduce problem
    – run sudo /etc/NX/nxserver --redis cmd save
    – copy nxdb file and send to us

    #31518
    Avatarbutsuriboy
    Participant

    As I mentioned in the email, I just sent the nxdb file (which I found at /usr/NX/etc/nxdb — I hope it’s correct), as well as an updated dump of server logs.  As I’d mentioned in the email, I had re-installed the NoMachine client on windows, wondering if that was the problem, and now, I don’t even get a flash of the connections page.  It goes straight from the NoMachine login page (where I enter my password) and straight to the message “The connection with the server was lost”.

    Thanks again for your help in trying to figure this out!

    #31774
    Avatarbutsuriboy
    Participant

    Any updates?

    #31947
    AvatarMth
    Contributor

    Hello.

    It does not seem the problem is on the NoMachine server side.

    From the logs:

    The user is indeed logged, the confirmation is sent to the player, but nothing else happens, not even closed connection. Then new connection is accepted and it hangs at the same place, there is third connection with the same fate. All three are closed on shutdown.

    The problem then seems to be either on the network or on the player side.

    Could you please provide the logs from the player? The instructions are in the same article, paragraph “Fourth Step: Collect Client Side Logs”

    /Mth

Viewing 7 posts - 1 through 7 (of 7 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.