Connection session at startup

Forums / NoMachine for Linux / Connection session at startup

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #13838
    Yuriy
    Participant

    Good afternoon, interested in the question. It is necessary to run the stored connection session at startup. Thank you.

    #13843
    Britgirl
    Keymaster

    To be able to answer we need to understand better 🙂

    Do you mean that you want to connect to a NoMachine server at the start up of the local machine e.g the machine from which you are connecting? If so, first we need to know the OS of the connecting client.

    We also need to know the type of session.  E.g. do you want to connect to the physical desktop or are you connecting to a virtual Linux desktop (i.e “virtual desktop session”)

    #13845
    Yuriy
    Participant

    OS Ubuntu 16.04 is NX server (a virtual machine), as well on Ubuntu 14.04 is NX client. The task at system startup, you need a client autostart, and the session that was previously created. Connecting usual, the NX protocol, a user with a password, without a proxy.

    #13853
    Britgirl
    Keymaster

    You haven’t said what type of session you want to run in NoMachine. Do you want to connect to the physical desktop or are you connecting to a virtual Linux desktop (i.e “virtual desktop session”). Look at Fig. 5 in the following tutorial to understand what I am asking: https://www.nomachine.com/creating-new-virtual-desktop-sessions

     

    #13864
    Yuriy
    Participant

     

    I connect to a real computer, that is, the physical desktop.

    #13952
    Tor
    Contributor

    You may configure the client to automatically start when logging in the Ubuntu session. There should be an application like “Startup Applications Preferences” to configure autostarting applications, or you may configure it manually by creating the file ~/.config/autostart/nxplayer.desktop with the following content:

    [Desktop Entry]
    Type=Application
    Name=NoMachine client
    Exec=/usr/NX/bin/nxplayer --session "path to the NXS file" --exit
    Icon=NoMachine
    Comment=NoMachine client automatic session
    X-GNOME-Autostart-enabled=true
Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.