Connection successful only one way

Forums / NoMachine for Windows / Connection successful only one way

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #34621
    mistikal
    Participant

    Hi all,

    I have a PC and laptop.

    I am able to connect to my PC through my laptop, but my PC wasn’t able to connect to my laptop.

    The error message is as below:

    A connection timeout has occurred while trying to connect to ‘192.168.0.125’ on port ‘4000’. The issue could either be caused by a networking problem, by a firewall or NAT blocking incoming traffic or by a wrong server address. Please verify your configuration and try again.’.

     

    How can I troubleshoot this problem? Both are connected to the same wifi.

    #34629
    Britgirl
    Keymaster

    Are you sure that you are using the correct IP address in the connection configuration? The IP address you pasted is one to use on the local network.

    What OS are on the computers?

    Are the two computers on the same network? Can you see the “other computer” (the one you want to connect to) in your Machines panel?

    #34631
    mistikal
    Participant

    I am sure it’s the correct IP address. I am just want to use it on the local network.

    Both using Windows.

    Both are on the same network. From my laptop connect to PC with IP 192.168.0.100. No issue. All connect successfully. Only my PC can’t connect to my laptop.

    I am not sure if my laptop refuses the connection or my PC cannot send the request. How can I troubleshoot this?

    #34638
    Britgirl
    Keymaster

    Try this….

    On the computer (PC), when you open the NoMachine player to connect to your laptop, does the laptop show up in Machines? See fig 5 in the following tutorial https://www.nomachine.com/getting-started-with-nomachine to understand what I mean. Computer hosts will be identifiable with a “double pipe” icon. Connections are identified with a !M icon.

    All NoMachine-enabled computers on the same LAN are visible by default in Machines. If you can see your laptop with the “double pipe” icon, double click on it to start the connection. Can you submit a screenshot of the Machines tab?

     

     

    #34639
    mistikal
    Participant

    Yes, it is visible right after I install and restart on both computers(PC & laptop).

    Both of them can see each other. The only issue, when I click the icon on the PC is not able to connect with the timeout error. But on the laptop, it’s working fine.

    #34714
    Britgirl
    Keymaster

    Select that icon and click ‘Edit’ and check what IP is being used. Check that this is the correct IP address just to make sure. Show me what you see.

    If it’s correct, it could be a non-native firewall installed on the server perhaps? Disable it temporarily to test connecting without the firewall.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.