Control keys not working for copy&paste

Forums / NoMachine Terminal Server Products / Control keys not working for copy&paste

Tagged: ,

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #20613
    Avatartimatgca
    Participant

    I have installed NoMachine Workstation evaluation on Ubuntu 18.04 running on AWS, and the Linux NoMachine Enterprise client.

    Installation was painless, and I have established a virtual desktop connection with no problems.

    However, my control keys don’t work. That is, I would like ctrl-C to do copy, for instance.

    Even when I’m running full screen and have grab keyboard input, when I do ctrl-C in Text Editor, my selected text is replace with the character ‘c’.

    I am stuck.

    #20625
    Avatargraywolf
    Moderator

    Hello, would you show the output of the following commands issued in a terminal window running in the virtual desktop:

    setxkbmap -print > setxkbmap.txt
    setxkbmap -query > layout.txt
    xprop -root | grep XKB > xprop.txt
    xmodmap -pke > xmodmap.txt
    xkbcomp -xkb $DISPLAY - > xkbcomp.txt

    #20932
    Avatartimatgca
    Participant

    I fixed this by starting with –activegrab

    e.g. /usr/NX/bin/nxplayer –activegrab

    although I also made a new launcher for gnome that starts it like this.

    I am connecting to NoMachine Workstation, gnome desktop, both server and client are ubuntu 18.04 and I have the Enterprise Client.

    So this completely fixes the problem, it seems. I wonder why this option is not much publicized when it makes such a difference?

     

     

    #20943
    Avatarsil04
    Keymaster

    Hi timatgca,

    by design NoMachine – in order to avoid to interfere with the Window Manager – relies on a ‘passive grab’ way: i.e. it intercepts the key press only when there is not an active grab. When the session is running at full screen, the client is for sure the only active application and it uses the ‘active grab’ way.

    This approach has been suitable for almost all situations, until now we are aware of a unique case in which it can be helpful to force always the active grab. This is when the pointer highlight is enabled:  https://www.nomachine.com/AR01P00959.

    The possibility to launch the client with the –activegrab option has been added to solve exactly this case.

    May you please tell us if you have the pointer highlight enabled too?

    #20944
    Avatartimatgca
    Participant

    Yes, I had “show pointer when control key is pressed” option, enabled by Gnome Tweaks (I am using ubuntu 18.04)

    When I turned this off, control key and function keys are passed through to the remote desktop session. Good catch, I would never have thought of this. So now there are two solutions.

    I think it may be worthwhile mentioning this with a bit visibility 🙂

     

     

    #20949
    Avatarsil04
    Keymaster

    Hi timatgca,

    thank you for confirming that you had the pointer highlight enabled. This case is described here:

    https://www.nomachine.com/AR01P00959
    How to send Control key to the remote desktop when the user has the pointer highlight enabled

    A hint for finding relevant information in our Knowledge Base (https://www.nomachine.com/knowledge-base) is to provide a keyword and restrict results to the area of interest (e.g. articles, trouble reports or feature requests).

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.