Core file with nxnode.bin

Forums / NoMachine for Linux / Core file with nxnode.bin

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #18336
    Avatarbeeblebrox
    Participant

    Hi, I am getting a core fairly frequently from nxnode.bin when using a virtual desktop from within a docker container.  Backtrace is attached.

    I had this issue in 5.x I upgraded to 6.1.6 because the update notes hinted at another core using a virtual desktop was fixed.  Unfortunatly, this core I am getting in 6.1.6 backtrace is pretty much identical.  It is always crashing on this stack:

    Thread 1 (Thread 0x7fe854ff9700 (LWP 718)):
    #0  0x00007fe8b2010f20 in GetULONG(unsigned char const*, int) () from /usr/NX/lib/libnx.so

    #1  0x00007fe8b203c630 in Realtime::findMessage(int, int&, int&) () from /usr/NX/lib/libnx.so

    #2  0x00007fe8b204a42b in Realtime::ackMessage(int, int) () from /usr/NX/lib/libnx.so

    #3  0x00007fe8b204adb7 in Realtime::read(int) () from /usr/NX/lib/libnx.so

    #4  0x00007fe8b201887e in DispatchFdList::callRunnables(IoRecord const*) () from /usr/NX/lib/libnx.so

    #5  0x00007fe8b202fe61 in Dispatcher::innerDispatch() () from /usr/NX/lib/libnx.so

    #6  0x00007fe8b2030d98 in Dispatcher::innerLoop() () from /usr/NX/lib/libnx.so

    #7  0x00007fe8b2030fe0 in Dispatcher::dispatch(int) () from /usr/NX/lib/libnx.so

    #8  0x00007fe8b207f04c in Threadable::loop(void*) () from /usr/NX/lib/libnx.so

    #9  0x00007fe8b31216ba in start_thread (arg=0x7fe854ff9700) at pthread_create.c:333

    #10 0x00007fe8b2e5741d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

     

    Environment info:
    Server: NoMachine vresion 6.1.6, Linux.
    Using Virtual Desktop
    Running from within Docker where the container is running Ubuntu 16.04.4 LTS,
    Host system is using: Linux 4.40-118-gener #143-Ubuntu SMP kernel x86_64

    Please advise if there is an option which can be a workaround for this issue until there is a fix. I’m looking forward to hearing a response.

    ~James

    #18346
    AvatarBritgirl
    Keymaster

    Hi, the file didn’t attach. Can you send it direct to forum[at]nomachine[dot]com? Make sure you reference your topic title. Thanks!

    #18374
    Avatarbeeblebrox
    Participant

    @Britgirl Attached here compressed (hopefully), but I’ll also send the email.

    #18401
    AvatarBritgirl
    Keymaster

    This is a known issue. Please try the workaround in the Trouble Report you can see here: https://www.nomachine.com/TR02O07628

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.