Could not acquire name on session bus

Forums / NoMachine for Linux / Could not acquire name on session bus

Tagged: 

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #18348
    Avatarbernd
    Participant

    After upgrading to Ubuntu 18.04 LTS and after successfully installing the Displaylink driver, I find that NoMachine Workstation version 6.1 no longer is accessible; opening a terminal session yields error “could not acquire name on session bus”. Unfortunately I can no longer tell whether this problem begun after the OS upgrade or the Displaylink driver installation. Otherwise the installation appears to be in good health.

    The Interweb has a few suggestions regarding the same error and other remoting tools such as VNC, such as the suggestion to “unset DBUS_SESSION_BUS_ADDRESS” to “~/.vnc/xstartup file after unset SESSION_MANAGER“. Obviously this is about VNC, not nomachine.

    Does anyone know how this error can be avoided with NoMachine, or where I might try to apply a workaround similar to the one suggested for VNC?

    #18368
    Avatarkroy
    Contributor

    We tried to reproduce on the fly but weren’t able to. We would need to know:

    – connection to what kind of session shows error? Is it connection to physical desktop, virtual or custom? (if custom – is it terminal or other app?)

    – which Ubuntu version did you have before the upgrade?

    – did you install NoMachine after the system upgrade?

    Can you enable debug (nxserver restart is needed – sudo /usr/NX/bin/nxserver --restart), reproduce problem, collect logs and send them to forum[at]nomachine[dot]com? Please send also node.cfg file (it’s in /usr/NX/etc/ directory). Instructions about debug and collecting logs you can find there:
    https://www.nomachine.com/DT10O00163

Viewing 2 posts - 1 through 2 (of 2 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.