Could not locate the SSH client?

Forums / NoMachine for Linux / Could not locate the SSH client?

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #1501
    rweede
    Participant

    Currently I am evaluating the Workstation version of NoMachine 4. I installed it on a server at work (Ubuntu 12.04) and am trying to connect to it with two different computers from home through SSH. one running Windows, another one running Ubuntu 12.04. Port forwarding has been set up correctly, everything worked previously with nomachine 3.5, and I can login manually through SSH on the command line.

    Connecting to a virtual desktop by SSH works correctly from the Windows machine. It also works with the NX protocol through a SSH tunnel from the Linux machine. However, when I try to connect directly through SSH, I always get “Can’t connect by SSH protocol. Verify that SSH is installed on your computer”. Of course, SSH is installed on my computer. As I said — connecting directly through SSH from the command line is not a problem

    The logfile on the client trying to connect shows:

    Connection: WARNING! Could not locate the ssh client at ‘/usr/NX/bin/nxssh.exe’.
    4054 4054 08:30:07 227,519 Connection: WARNING! Could not initialize the connector.

    The logfile on the server does not indicate any attempt to connect.

    I don’t really understand the client logfile: Of course, there is no “/usr/NX/bin/nxssh.exe” on the Linux installation — the executable is called “/usr/NX/bin/nxssh”.

    What am I doing wrong?

    #1517
    Britgirl
    Keymaster

    I suspect that on your Linux client machine you are using a configuration file (nxplayer.cfg) created on Windows. Could that be possible? If this is the case, the nxplayer.cfg file on your Linux host will have the SSH Client key set to nxssh.exe:

    You can check whether this is the case by:

    $ cat nxplayer.cfg | grep nxssh

    If you get:
    <option key=”SSH Client” value=”nxssh.exe” />

    change it to:
    <option key=”SSH Client” value=”nxssh” />

     

    #1547
    rweede
    Participant

    $ cat nxplayer.cfg | grep nxssh

    If you get:
    <option key=”SSH Client” value=”nxssh.exe” />

    change it to:
    <option key=”SSH Client” value=”nxssh” />

    Thanks, that did it. I’m wondering whether this may be a bug in the Linux installation package. As far as I remember, I never copied a config file from a Windows machine. Not 100% sure, though.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.