Credentials are not forwarded inside the session when using Pageant or KeeAgent

Forums / NoMachine for Windows / Credentials are not forwarded inside the session when using Pageant or KeeAgent

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #23742
    Avatarpeterarien
    Participant

    Regarding https://www.nomachine.com/TR09P08830

    I’m running NoMachine server 6.6.8 on Linux, and Client version 6.8.1.

    This should have been solved in 6.5, but the problem is still there. Is there anything we can do to give this a higher priority?

    For now we’re forced to use a workaround with a separate putty-session that handles the agent-connections. But where the nx-client is very good at transparantly renegotiating its connection after a network change (undocking the laptop, going to a meeting, …), putty just drops the connection.

    #23751
    AvatarBritgirl
    Keymaster

    Fixing it is not so simple, because we need to add support explicitly for KeeAgent/Pageant. The FR has been made public here: https://www.nomachine.com/FR09Q03877

    If you are using Putty, you could try using the option ‘Private key’ authentication with ‘Forward authentication’ option checked, making sure that it’s in the OpenSSH format or convert it. To do that choose the key file in the PuTTYgen main window. Then go to Conversions->Export OpenSSH key to export your private key and save it.

    Some useful info about key based authentication with NX protocol here and for SSH protocol is available here: https://www.nomachine.com/AR02L00785  and https://www.nomachine.com/AR06O00932

    btw, when a TR has a “due to be fixed in ” version, it indicates a target, we can’t however guarantee that the a fix will be found, and the target should change to the version that we are currently on.¬† For some reason, that particular TR wasn’t updated to show a later target version.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as closed, you can't post.