Ctrl combinations ignored

Forums / NoMachine for Linux / Ctrl combinations ignored

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #14602
    Avatardkebler
    Participant

    Just installed latest 5.2.12 on both a debian Jessie and Ubuntu 16.04 box.

    All ctrl keyboard combinations  are ignored.  For example if I have a terminal open on the host via the client and do a ctrl-c I just get a c in the terminal.  It’s the same in all programs all the keyboard shortcuts that start with ctrl are ignored.   For example I am not able to use nano remotely as it’s all ctrl key driven.

    When I use vnc passing ctrl combinations is not an issue so this seems NoMachine specific.

     

     

     

    #14613
    Avatarkroy
    Contributor

    Can you check if the problem still exists with activated “Grab the keyboard input” option (you can find it in the nxplayer options – in the “Input” section https://www.nomachine.com/DT11M00106#2.1)? Does the issue show during connection from Debian to Ubuntu physical desktop? What desktop environment is installed on the affected machines?

    #14616
    Avatardkebler
    Participant

    I discovered the issue.

    If you are using a gnome based client it has a setting ” show position of cursor when control key is pressed”  this setting grabs the cntrl key keypress before it can be sent to the NoMachine host.   Just disable this feature in the mouse settings and all is well.

    Also it can be diasabled directly in the gconf settings.  see these two webpages.

    ctrl-key-not-working-in-vnc (link removed)

    how-do-i-use-the-gconf-editor (link removed)

    #14634
    AvatarTor
    Contributor

    Hello. What you’ve discovered is correct, although you can make NoMachine client and locate pointer feature cohexist.
    The setting helping us is “Grab the keyboard input”, but to catch this particular keystroke we need an additional command line option described in nxplayer --help:

    --activegrab

    When the setting ‘Grab the keyboard input’ doesn’t catch all keys, use this
    option to force a different grabbing mode. The client will catch keys only
    when the cursor is inside the window.

    With this configuration you’ll be able to send the Ctrl key to the remote desktop, but of course the local cursor will not be highlighted when it is on the NoMachine client window.

    #14783
    Avatardkebler
    Participant

    Ok,  I did as you suggested and yes the NoMachine player window supersedes the client OS keyboard.

    Not that I needed that gnome mouse feature but one can now leave it on if desired.

    So

    is there and  activegrab key that can be set in the player.cfg file??

    That would be easier than an option on the comand line.

    #14819
    AvatarTor
    Contributor

    Hi. It is not currently possible, but we’ll add it in future. Please subscribe the following Feature Request to be notified when we’ll release it:

    Adding a new key in player.cfg to toggle ‘activegrab’ option
    https://www.nomachine.com/FR05O03411

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.