Ctrl/command shortcut keys for Windows

Forums / NoMachine for Windows / Ctrl/command shortcut keys for Windows

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #32547
    Avatardzmadmin
    Participant

    I have users with NoMachine on their Windows VM connecting to MacOS and are unable to use ctrl/command keyboard shortcut keys. I had them test using ctrl or Windows key (in place of command) with “Grab the keyboard input” both turned on and off. No shortcut keys seem to work such as copy/paste or in-program shortcuts like command + f  for search. \

    This appears to be a similar issue to this thread: https://forums.nomachine.com/topic/control-keys-not-working-for-copypaste but I have not found a way to enable activegrab in the Windows version of NoMachine. Is there a way to do this or is there another configuration I should try to fix this issue?

    Thanks!

    #32568
    AvatarTor
    Contributor

    Hi. Could you tell us what is the VM software, Windows and macOS versions? We’d like to run a test.
    The grab keyboard input on Windows is always “active” and we’re not aware of such difficulties in using keyboard shortcuts, so we need to understand what is interfering with the input catching. I’ve some questions:

    • Are all shortcuts ignored in the same way, or some of them pass through?
    • When a shortcut is ignored, does it trigger an action on Windows?
    #32569
    Avatardzmadmin
    Participant

    Thank you for the response. We are using:

    VMware Horizon Client 5.4.1
    Windows 10 1809
    MacOS Big Sur

    We are able to copy/paste from/to the Mac and Windows VM. Occasionally I can get it to copy-paste on the Mac I am using through NoMachine by doing a “windows key” + c and “windows key” + v, with “Grab the keyboarding input” turned on but sometimes it does not respond to those shortcut keys and nothing happens. On a physical Windows machine running VMware it triggers a message saying that copied items have been save to clipboard. We also use zero clients that connect via VMware, and with that, I get no message when doing copy/paste.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.