Debian 10 high CPU usage

Forums / NoMachine for Linux / Debian 10 high CPU usage

Tagged: 

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #38052
    markolbert
    Participant

    I have the free version of NoMachine running on a debian 10 system. I’ve noticed that even when not in use it’s consuming a significant amount of CPU resources (e.g., atop reports the overall load as exceeding 50%).

    The VPS I’m running this on is relatively small (i.e., 2 cores, 2GB of RAM). But I’m still curious if there’s something I should’ve tweaked to manage how NoMachine is operating in “standby”.

    Or maybe I’m getting pounded by attempts to break into the system?

    #38088
    Britgirl
    Keymaster

    Hi, you don’t mention what version you are using. We recently fixed a bug in the release affecting 7.8.2 related to mDNS which was causing behaviour like you described.

    High CPU usage of NoMachine Client on Ubuntu when listing the available machines and connections
    https://knowledgebase.nomachine.com/TR09S10371

    If you are using 7.8.2 and don’t want to update to 7.9.2, you can use the workaround mentioned in the TR i.e disable network¬† browsing. Open the client UI -> Settings -> Player -> Security and select ‘Don’t show other computers on the network’.

    If you are already using 7.9.2, please send us the exact output of “top”, “top -H” (to also get the exact thread consuming the CPU), “atop” or whatever command you are using to get the system load.” We aren’t aware of reports of abnormal CPU usage in this version.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.