Debian 9 display unavailable

Forums / NoMachine for Linux / Debian 9 display unavailable

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #20002

    When connecting to my Debian 9 server from my Windows 10 laptop today, I received the message “Display unavailable, do you want to add a new one” or similar

    As the server is sat next to me and I could see all was ok I clicked ‘Yes’ – it failed, but now when I power up the server, the screen just goes black, and flickers occasionally – on the Debian 9 server.

    Is there a way to disable NoMachine on startup so that I can reinstall it?  I believe it is NoMachine that is causing the server display issues. I am not a Linux guru.


    Which version of NoMachine are you using?

    In order to disable automatic startup of NoMachine on boot, get a shell as first thing. If you are next to the server, just type key-combo Ctrl+Alt+Fn (where Fn = F2 or F3 or F4 …).

    After you logged in and got the shell, type the command:

    /usr/NX/bin/nxserver --startmode manual

    then reboot the system with

    Could you create an archive of /usr/NX/var/log folder? Use the command
    tar zcvf NoMachineLogs.tar.gz /usr/NX/var/log

    then send the file NoMachineLogs.tar.gz to the email address: forum[at]nomachine[dot]com


    Thanks for the response, the server’s now in the other room, so I’ll start it in rescue mode and set the startmode to manual

    I’ll then try and get the log over.

    If this works I’ll love you forever as I’ve been snapshotting my server with clonezilla, and now I need it, it won’t restore any of the images.

    NoMachine rocks, by the way!



    Recovery mode and –manual means I have my server back –
    THANK YOU! and for the speed of response.

    I’ll get the logs onto a USB stick and sent to you in the next hour or so.

    Do you suggest an uninstall/reinstall of NoMachine or is there a way to reset the options that will probably fix it?



    logs sent – with thanks



    Server logs don’t say very much. Could you search the systemd journal for errors? Just run the command

    You can restict the search to the last boots using the option -b:
    journalctl -b -0 (the last boot)
    journalctl -b -1 (the boot before last)
    journalctl -b -2 (and so on)


    There’s nothing beyond last boot. I’m currently uninstalling and reinstalling it to see if that work…

    if it happens again I’ll log everything and send it on



    @netyoda, did reinstalling help? If you’re still having the same problem, let us know.

Viewing 8 posts - 1 through 8 (of 8 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.