Desktop is not shared

Forums / NoMachine for Windows / Desktop is not shared

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #32155
    Avataralmnofie
    Participant

    I have been using NoMachine for a year, but now I cannot call remotely because I cannot activate the shared desktop option on the server settings.
    Look at the attachment.

    NoMachine is the current version.

    What is the problem?

    #32192
    AvatarTor
    Contributor

    Hi. Did you try to enable desktop sharing by using the link in the bottom-right corner of the client window?
    You can find a description here:

    https://www.nomachine.com/DT11R00177#3.7.

    #32193
    Avataralmnofie
    Participant

    Yes, I have. But I can not because it is inactive.

    #32197
    AvatarTor
    Contributor

    Please open a Command Prompt window and let me the output of the following command:

    find "EnableAcceptingConnection" "%ProgramFiles(x86)%\NoMachine\etc\node.cfg"

    #32409
    Avatarmymachines
    Participant

    Did you ever get this solved?

    I have the same problem. My server always has “Desktop not shared” in the server status page and the toggle in the lower right is greyed and not clickable.

    I set EnableAcceptingConnection 1 in node.cfg (it was #’d out). No difference.

    I have a 2 monitor Win10 machine as server. I’ve opened up the firewall to everything “nx”. I’ve read a heap of tutorials, NoMachine FAQ’s but nothing is making any difference.

    About to give up and return to [removed] as I can’t believe such a basic “feature” as viewing a remote desktop is not automatically configured in a remote desktop application! Very weird.

     

     

    #32418
    Avataralmnofie
    Participant

    yes, is working

    thank you

    #32420
    AvatarTor
    Contributor

    I have the same problem. My server always has “Desktop not shared” in the server status page and the toggle in the lower right is greyed and not clickable.

    Hi mymachines, and welcome!
    The control is greyed out when your desktop can’t be shared or when there is no way to change the status, but I guess you already knew this! 🙂 Let’s see why this can happen.

    1. Your server is not running. You can easily verify this by opening the Settings > Server > Status.
    2. Your server is configured to not allow the desktop sharing. You can confirm it by checking the status of the box “Share the desktop at server startup” in the Server Status panel.
    3. Your NoMachine client is running in a Windows Terminal Server. In such a case NoMachine can’t access to the RDP desktop, thus the client can’t change the sharing configuration. I suppose this is not your case, I’m listing it only to give complete information.

    If you confirm you’re not in any of the above cases then you could have an unexpected issue, so let’s debug it!
    Please open the command prompt and run the command "%ProgramFiles(x86)%\NoMachine\bin\nxserver" --status (binary path between double quotes), what’s the output?
    Open a file browser and enter the folder %ALLUSERSPROFILE%\NoMachine\var (you can paste the path in the address bar), then compress the folder “log” and send it to forum[at]nomachine[dot]com by using the topic title as subject.

    #32421
    Avatarmymachines
    Participant

    Thanks Tor.

    1. Server is running. I’ve stopped and started it a number of times.

    2. Share at startup is ticked.

    3. Not running terminal Service.

    Result of nxserver –status:

    NX> 111 New connections to NoMachine server are enabled.

    NX> 162 Enabled service: nxserver.

    NX> 162 Disabled service: nxnode.

    NX> 162 Enabled service: nxd.

    Log folder emailed.

    Thanks heaps.

    #32492
    Avatarmymachines
    Participant

    Just wondering if there is any advice regarding this?

    It would appear to me (the uneducated) that the line  162 Disabled service: nxnode is possibly key to this, but I haven’t found how to enable that service.

    I’ll email the log folder again in case that’s gone missing.

    #32623
    AvatarCarin
    Participant

    Hi mymachines,

    Unfortunately, the logs you submitted didn’t help us. We would like to send you a debug package and extract the logs again (after you’ve reproduced the problem). Would this be ok for you?

    #32625
    Avatarmymachines
    Participant

    Hi Carin,

    Yes that would be fine.

    Thanks

    #32700
    AvatarCarin
    Participant

    We have sent you the package. Check your inbox 🙂

     

    #32751
    Avatarmymachines
    Participant

    Debug package installed.

    Problem remains.

    Logs sent by email.

    Thanks.

    #32780
    Avatarparanoidroid
    Participant

    I have seemingly the same issue.

    find "EnableAcceptingConnection" "%ProgramFiles(x86)%\NoMachine\etc\node.cfg"
    
    ---------- C:\PROGRAM FILES (X86)\NOMACHINE\ETC\NODE.CFG
    #EnableAcceptingConnection 1
    "%ProgramFiles(x86)%\NoMachine\bin\nxserver" --status
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 161 Enabled service: nxnode.
    NX> 161 Enabled service: nxd.

    I have also sent the zipped log folder from %ALLUSERSPROFILE%\NoMachine\var to forum[at]nomachine[dot]com.

    When I try to connect to the machine even though it says that the desktop isn’t shared, I can see the prompt for username and password and when I enter them I get disconnected. The connection is then retried a few times until it gives up.

    #32812
    AvatarCarin
    Participant

    Hi @mymachines,

    we have received your logs, but we will need additional debug logs. We kindly ask you to enable debug logs for nxnode and nxserver as described in this article: https://www.nomachine.com/DT11R00181#1.4.

    The steps are the following:
    1. Enable additional debug logs for nxnode and nxserver (as described in the article) .
    2. Reproduce the issue.
    3. Send us the new logs, node.cfg and server.cfg.

    Can you please send them directly to forum[at]nomachine[dot]com making sure you use the title of the topic in the subject of your email? Many thanks!

Viewing 15 posts - 1 through 15 (of 20 total)

You must be logged in to reply to this topic.