Desktop only VGA resolution

Forums / NoMachine for Linux / Desktop only VGA resolution

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #279
    Avatarkermitsalon
    Participant

    I am running the latest nomachine windows xp client off my ubuntu 13.10 headless server. Connection and everthing is fine but the virtual desktop is stuck at 800×600 resolution. The server is running the nouveau driver and I am using the default ubuntu desktop. However, the desktop is not the problem, I can switch to different desktops with no problem (Gnome, Cinnamon, Ubuntu). I have tried to change to a proprietary (in my case nvidia) driver but that doesn’t change anything. Anyone experiencing similar headaches?

    #289
    Avatarsil04
    Keymaster

    Hi kermitsalon,

    what product did you install on the server? Are you connecting to the physical display or a virtual display session?

    #290
    Avatarkermitsalon
    Participant

    Hi sil04,

    on the server I am running the latest nomachine deb 32 bit package (4.0. 264) on ubuntu 13.10.

    client is standard windows XP client software (4.0.360) connected via local lan.

    I will try upgrading my server to 4.0.360

    #292
    Avatarsil04
    Keymaster

    Which package? Free NoMachine version, Workstation Enterprise Server?

    If you installed the free version you should get the physical display exported.

    Since you say that the machine is headless, probably this machine gets a default Xorg.conf configuration, set up by Ubuntu at installation time.

    NoMachine doesn’t change this Xorg.conf and it is not responsible for setting up Xorg to support a wider range of resolutions. You should try in the Ubuntu control panel or refer to the Ubuntu documentation.

    You should be still able to set a “virtual X server” using the instructions here:

    http://www.nomachine.com/AR10K00710
    How to use NoMachine on a headless Linux server

    Then NoMachine should be able to attach to it just fine.

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.