Difficulty mapping?

Forums / NoMachine for Mac / Difficulty mapping?

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #30764
    Avatarwsnyder4
    Participant

    Hi NoMachine experts,

    I am using a MacBook Air (2020) to remote into a Linux machine (18.04) with NoMachine installed on it. I can ssh successfully through the terminal but can’t get NoMachine screensharing to work, and keep receiving an error that the server is not running. Within my own router, I used NoMachine to successfully screen view the Linux, but now that the Linux is on a corporate server I am having difficulties.

    The session file starts to go downhill following “ClientUpnp: WARNING! Mapping of port ‘4035’ failed”

    I tried manually opening port 4000 and mapping it to my Linux’s IP but no success here. I have read in other posts that failed auto UPNP mapping may be the issue but this workaround hasn’t worked for me (or maybe I am just configuring this wrong? I tested with ports 4000, 22, and 4035 but no such luck)

    Additionally the connection file says “Warning: no access to tty (inappropriate ioctl for device” but idk if this is contributing.

    Any help will be greatly appreciated!!

    #30976
    AvatarBritgirl
    Keymaster

    From what I understand you’ve used NoMachine without any problems on your own local network, but now that you’re on a corporate network, you can no longer connect to the Linux server because of multiple port problems.

    If you submit the logs from both client-side and server-side, we can check to see if it’s a network problem or a configuration one. Please submit them to forum[at]nomachine[dot]com. Instructions on how to extract are available here:  https://www.nomachine.com/AR10K00697

    #32056
    AvatarBritgirl
    Keymaster

    No logs received, so closing this.

Viewing 3 posts - 1 through 3 (of 3 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.