Disable certain shortcuts to be sent to the remote host

Forums / NoMachine for Linux / Disable certain shortcuts to be sent to the remote host

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #34977
    deman
    Participant

    Hello there. I am using NoMachine for about 1-2 years now and I am pretty happy with it. I use it on my Linux machines to connect VMs and work remotely on them.

    In Linux you have multiple desktops. I have the NoMachine window open on it’s own desktop in fullscreen mode and have keyboard grabbing enabled.

    Is there a way to prevent a certain keytroke to be grabbed by NoMachine? I switch my desktops by using “CTRL+ALT+CURSOR_KEY”, but this shortcut is grabbed by NoMachine. Currently I disable keyboard grabbing by it’s own shortcut, than switch desktops and enable grabbing again, when coming back to NoMachine.

    TL;DR:  I want ctrl+alt+cursor_key_left/right excluded from NoMachine keyboard grabbing.

    Thanks in advance.

    #34980
    Carin
    Participant

    Hi deman,

    Thank you for sharing your use case with us.

    Unfortunately, this is not possible. In fullscreen mode, NoMachine uses active grabbing so all keys and shortcuts are grabbed.

    #34991
    deman
    Participant

    Alright, thank you Carin.

    #35228
    solotim
    Participant

    Hi, Carin,

    Is it possible to disable literally all shortcuts of NoMachine client?

    thanks

    solotim

    #35246
    solotim
    Participant

    Especially I hate the fact that “Ctrl+Alt+k” turns on/off the “grab keyboard input” option. This is very annoying. I don’t want any shortcut of NoMachine itself.

    #35317
    Carin
    Participant

    Hi @solotim,

    It is possible to disable the shortcuts in the Shortcuts dialogue of the Input menu. The Shortcuts button in the Input menu opens the list of shortcuts and they can be selectively disabled.
    If you want to disable all the shortcuts, this can also be done from the Player Settings, by unchecking the box “Use keyboard shortcuts for quick actions”.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.