Disable file transfer with firewall

Forums / NoMachine for Windows / Disable file transfer with firewall

Tagged: 

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #32352
    AvatarNoMachineNewUser101
    Participant

    Hello,

    What ports and protocols are required for NoMachine’s file transfer? I Have an instance where users are in a segmented network and I don’t want them to be able to transfer files or mount drives between the two networks. For instance with RDP we disable SMB and SSH to prevent users from moving files to/from the LAN to the segmented network, how would we do this with NoMachine ? Is there somthing we can block on the firewall? I know you can configure NoMachine to disable filetransfer, but would the users be able to easily re-enable it themselves?

    Thanks

    #32359
    Avatarfisherman
    Moderator

    You can check this document https://www.nomachine.com/DT11R00185 Enabling and disabling the NoMachine device sharing services manually.

    All needed configuration requested will require administrator rights.

    about used ports in NoMachine you can check following Link https://www.nomachine.com/AR01L00770 Default ports used by NoMachine 4 or later

    #32361
    AvatarNoMachineNewUser101
    Participant

    So if I only have Port 4000 open, I’ll be able to remotely connect to a machine but I won’t be able to transfer files between the hosts? In order to do this I would have to enable ports 22 or 4022?

    #32424
    Avatarfisherman
    Moderator

    If you want to disable file transfer, you can do this by editing the cfg files as explained in that article I mentioned in my earlier reply. I don’t know what permissions your users have. If they don’t have administrator rights on the server, then they won’t be able to re-enable it.

    Or you can do it in the server UI itself. Again, this depends on what permissions your users have on the server host. If the connecting user is an admin user, it’s impossible to prevent them from accessing the server preferences.

    Regarding the ports, you must have port 4000 open in order to accept connections in general. If you disable it, you won’t be able to connect at all. Ports 22 are for SSH connection on Mac/Linux and 4022 on Windows.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.