Disable MDNS

Forums / NoMachine for Linux / Disable MDNS

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #7477
    Avatarbeju
    Participant

    Hello all!

    I have just started my adventure with NoMachine. One of first things I noticed upon starting the server is that it’s spamming my external interface with MDNS packets on port 5353. Is it possible to turn this service off somehow? I really don’t need it.

    #7510
    AvatarBritgirl
    Keymaster

    You have enabled broadcasting to let other computers discover you on the local network.
    There are two ways to disable the ‘Advertize on the network’ feature. Uncheck the box in Fig 1 in the tutorial here:

    https://www.nomachine.com/finding-other-nomachine-computers-on-the-same-network

    Or you can disable it in the server.cfg file on the server host:

    # Enable or disable broadcasting the required information to let
    # other computers discover this host on the local network.
    #
    # 1: Enabled. Other computers on the local network can find
    # this host machine.
    #
    # 0: Disabled. This computer cannot be found on the local
    # network but it’s still reachable by providing its IP
    # or hostname.
    #
    #EnableNetworkBroadcast 0

    A restart will be required for it to take effect.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.