Disable nxplayer on server

Forums / NoMachine Cloud Server Products / Disable nxplayer on server

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #5372
    Avatarsnejok
    Participant

    Hello, dear NoMachine!

    I have several servers. My users very curious, and often I find that they start second virtual session from first virtual session.

     

    1. As you adviced I moved nxplayer.bin and created a shell script with “exit 255”, this helped.

    https://www.nomachine.com/forums/topic/server-cfg-settings-nx-disable-client-using-server-cfg

    2. Also you adviced remove a binary:

    https://www.nomachine.com/forums/topic/install-only-nxplayer-and-only-server-pcs

    But I noticed that I can’t start a virtual session when I removed nxplayer.bin. Nxplayer’s connection window shows spinning gif for 120 sec and then shows an error:

    “The session negotiation failed.

    Error: NXClient –monitor exceeded maximum initialize time of 120 seconds.”

    3. See my post where I asked for “Cancel button” on “Creating a new virtual desktop” screen https://www.nomachine.com/forums/topic/clicking-on-spinning-animation-closes-nxplayer-window/#post-5283

    4. Could you add an option to node.cfg for disabling “Browse connections” and “New connections”? This buttons not work after “exit 255”, but they confuse my users.

     

    Server: ALT Linux 6 x86_64 with nomachine-enterprise-server-evaluation_4.3.30_2_x86_64.rpm

    Client: ALT Linux 6 i586 with nomachine-enterprise-client_4.3.30_1_i686.rpm

     

    #5395
    AvatarBritgirl
    Keymaster

    3. See my post where I asked for “Cancel button” on “Creating a new virtual desktop” screen https://www.nomachine.com/forums/topic/clicking-on-spinning-animation-closes-nxplayer-window/#post-5283

    Snejok, that post will be updated soon by the developer. Adding a cancel button to the GUI is not as simple as you may think, but I am sure the design team will evaluate if it can be done or not.<

    4. Could you add an option to node.cfg for disabling “Browse connections” and “New connections”? This buttons not work after “exit 255″, but they confuse my users.

    Can you open another topic so we can keep things separate?

    #5436
    AvatarTor
    Contributor

    But I noticed that I can’t start a virtual session when I removed nxplayer.bin. Nxplayer’s connection window shows spinning gif for 120 sec and then shows an error:

    This should not happen, we’ll investigate it. Did you also try to remove the execution permissions on nxplayer.bin, or just limit them to the file owner?

    #5592
    Avatarsnejok
    Participant

    Tor, thank you.

    I removed the execution permissions on nxplayer.bin and everything works as expected for me.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.