Disabling the creation of a new desktop but enabling the connections to existing

Forums / NoMachine for Linux / Disabling the creation of a new desktop but enabling the connections to existing

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #30139
    Avatarjeremy.fix
    Participant

    Hello, my use case is the following : I want to allow users to be able to connect to already existing sessions without being, by default, allowed to create new virtual desktop.

    To explain more the context : we do have NoMachine Workstation installed on a CPU cluster managed by a resource scheduler (SLURM). For now, we explicitly enable the logins (with nxserver –userenable) as soon as it has been allocated a node and only on the NoMachine server running on the assigned node. Once the CPU resource is freed for the used, we userdisable it to prevent him from accessing NoMachine if there is no allocation of the node (and possibly use the resource without the SLURM scheduler being aware of it).  So far so good.

    However, we do that in a university where students may have to work on a shared virtual desktop (actually, I’m in France, where we just get confined) and my problem is that if a student B wants to connect to a virtual desktop created by its colleague student A, it cannot because his login is userdisabled and only the login of user A has been enabled.  So, in the way I’m thinking about it, I do feel a need to allow users to connect to NoMachine to possibly access existing virtual desktops  while still being unable to create virtual desktops on the nodes they did not allocate with the scheduler we use.

    I don’t know if there is a possibility to do that or maybe the userenable/userdisable  we use so far is not the right track ?

    Thank you for your help;

    Jeremy.

    #30202
    Avatarbrotech
    Participant

    Hello Jeremy,

    im not sure, but maybe its enough to set limit for virtual sessions?
    Its available to set in server configuration file:

    #
    # Set the maximum number of concurrent virtual desktops.
    #
    #VirtualDesktopsLimit 20

    file: /usr/NX/etc/server.cfg
    set:

    VirtualDesktopsLimit 1

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.