Disconnecting after several seconds

Forums / NoMachine for Linux / Disconnecting after several seconds

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #28953
    Avatardanart
    Participant

    I’m trying to connect from a Win 10 PC to a Linux PC. Updated NM on both machines and restarted them.

    The default port (when I open NM on the Windows machine and automatically see the Linux PC) for some reason is 3389 and if I change it to 4000 I can’t connect.

    I have a displayport cable connected to the Linux PC but it’s not connected to a monitor.

    In the past (a year ago) I could connect to the Linux PC without any problems.

    Here are the only messages I get in the /usr/NX/var/log/nxserver.log file:

    2020-08-10 18:32:20 224.130 11010 NXSERVER User ‘barat’ logged in from ‘xxx.xx.207.27’ using authentication method NX-password.

    2020-08-10 18:32:26 177.369 11048 NXNODE   ERROR! Application terminated too early.

    2020-08-10 18:32:27 179.043 11048 NXNODE   ERROR! PulseAudio with pid 11135 did not finish after terminate within ‘1’ second.

    2020-08-10 18:32:27 182.333 11048 NXNODE   WARNING! Process ‘/usr/bin/pulseaudio –high-priority=no’ with pid ‘11135/11135’ finished with signal 9 after 4,61

    2020-08-10 18:32:27 307.614 11010 NXSERVER User ‘barat’ from ‘xxx.xx.207.27’ logged out.

     

    #28985
    AvatarBritgirl
    Keymaster

    – What distro is on the server?
    – What NoMachine version and official products did you download from our website? If this is the free version – are you sure that X server is started there?
    – What is the desktop environment installed there? You can check by executing in a terminal: sudo grep DefaultDesktopCommand /usr/NX/etc/node.cfg

    The port we use by default is 4000. Who could have changed it to 3389? Where is the host that you are connecting to? Is it under your control?

    #29280
    Avatardanart
    Participant

    Hi, thanks for the reply.

    The on the machine I try to connect to, the distro is Ubuntu 16.04.5 LTS (Xenial Xerus)

    I’m using free nomachine downloaded from the official site version 6.11.2 on both machines.

    I’m not sure about the x server as everything worked before with the older nomachine versions. But I tried installing x server on the remote linux machine and still had trouble connecting.

    output for DefaultDesktopCommand :  “/etc/X11/Xsession ‘gnome-session –session=ubuntu'”

    Probably I changed the default port few years ago  but I can’t really remember.

    When I try to connect to this machine it asks me “Cannot detect any display running. Do you want NoMachine to create a new display and proceed to connect to the desktop?” After I press “yes” it is connected for a few seconds and shows the wallpaper of the remote linux and then disconnects.

    Would appreciate any help.

     

    PS: isn’t it great how this free software harass me to download updates every few days, yet after I update it completely breaks its core function 🙂 but hey, its free!

     

    #29483
    Avatardanart
    Participant

    Upon further testing, restarting the remote linux PC, then connecting a monitor and logging in seems to solve the problem. I tried connected with NoMachine while logged in with a monitor to the remote PC and was successful. Then I logged off and disconnected the cable from the monitor of the remote PC and connected successfully to the remote PC as well.

    Not a real solution for someone without access to the remote PC but that worked form me.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.