Display doesn't update with small changes

Forums / NoMachine for Linux / Display doesn't update with small changes

Tagged: , ,

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #10116
    NNois
    Participant

    Hi,

    I’m new to NX, here’s my problem, using NoMachine session with the NoMachine client 5.0.63 on a local GB network.

    While the display is pretty fast and good small updates on the screen like a cursor in a terminal window, or small ticks on apps UI aren’t displayed untill something bigger change.

    For example in our software if we tick an option in the UI, the ticked mark doesn’t come, so we feel it’s not ticked, I’m sure you can imagine how it’s not possible to work like that.

    I’m sure too i can tweak some setting somewhere but in an ideal world this option should be on by default…

    #10121
    Britgirl
    Keymaster

    There should be nothing to tweak to in order to show ‘ticks in boxes’ in the remote desktop session. What OS do you have on the client side? What OS & version on the machine you are accessing? What product and version from our website did you install? What application, with these check boxes that you need to tick, is it?

    #10125
    NNois
    Participant

    ok, let’s get this clear

    – This is not a problem of checkbox but a problem of “size” of “changes” in the remote session. If changes are really small like a blinking cursor or a thick box they are delayed about some seconds

    – I’m using version 5.0.63_1 amd64 DEB on 4 Ubuntu 15.10 machines

    – The client is version 5.0.63_1 on a Mac (tested with another mac too reproducing the problem)

    here’s a small example in image, you could see on the first the blinking text cursor is missing and not streamed to the client… i can only see it if i move it left to right 2 or 3 times or if i move a little the windows for example…

    very odd, i feel it’s a problem of keyframe in the videocodec or something like that

    #10135
    fra81
    Moderator

    Can you please provide some more info:

    – Are you connecting to a physical or a virtual display?

    – What is the desktop evironment in use (Gnome, KDE, …)?

    – A screenshot of the Display settings panel: Open the session menu -> Display -> Change settings.
    Among other things, there is indicated the codec in use.

    #10149
    NNois
    Participant

    – I’m connecting to multiples computers to Physical Display (to preserve OpenGl capabilities of 3d application we use)

    – That’s Ubuntu Gnome 15.10 so 3.16.4

    – please fin the screenshoot attached, the codec seems to be vp8. The adaptive is deactivated but that’s simply an unsuccessful test to get rid of this very annoyance refresh thing

    #10151
    NNois
    Participant

    Here’s another screenshot, showing the display setting, trying to change codec to h264 but still, the connection stays to vp8. Tried too forcing a 30fps but the bug stays the same (tested after reboots)

    How can i test with h264 (client is a macos, and server ubuntu gnome 15.10) ?

    #10152
    NNois
    Participant
    #10171
    fra81
    Moderator

    Please try to add the following line to the ‘/usr/NX/etc/node.cfg’ file on your server machine and restart the server (‘/usr/NX/bin/nxserver –restart’):

    DisplayServerExtraOptions “-nodamage”

    That should confirm if the problem is due to an incorrect event reporting from the Damage extension.

     

    Here you can find the relevant info about H.264:
    https://www.nomachine.com/AR10K00706

    #10506
    NNois
    Participant

    Hi,

    So I’m back to solve this for our machines.

    I can confirm you than adding the extra option -nodamage solve the problem.

    I assume now NoMachine use more bandwidth. While the display seems for now pretty fluid how can i fix that damage extension, Is that on your side ?

     

    Cheers

    #10519
    fra81
    Moderator

    Hi,

    that option won’t cause any increase in bandwidth usage. NoMachine does most of the work and uses the Damage events reported by the system only as hints.

    #10563
    NNois
    Participant

    ok, that switch isn’t working with a physical display session…

    with “DisplayServerExtraOptions “-nodamage” ” the client can’t connect and the message is

    1. It seems that a new display has been already started… connect to it ?

    2. <No available sessions on this server>

    without this switch I see none of the two message above and NoMachine connect correctly to the desktop but with a problem of refresh on small things

    It’s with the last updated client , Ubuntu 15.10 , Gnome

    • This reply was modified 5 years, 10 months ago by Britgirl.
    • This reply was modified 5 years, 10 months ago by Britgirl.
    • This reply was modified 5 years, 10 months ago by NNois.
    #10633
    fra81
    Moderator

    Sorry but I’m a bit confused now. What do you mean  with ‘physical display session’? In your previous post you were saying that the option solved the problem when connecting to the Physical display.

    Anyway, from the message that you copied, this seems a different problem. We would need the server side logs to tell what is wrong. You can find instructions on how to gather them here: https://www.nomachine.com/DT07M00098. You can send them to forum[at]nomachine[dot]com by referencing the title of this topic.

    #10807
    Britgirl
    Keymaster

    Reporting on behalf of the NNois:

    You says

    What do you mean  with ‘physical display session’? In your previous post you were saying that the option solved the problem when connecting to the Physical display.

    I have two types of nodes where i’m connecting, ones with no displays attached so NoMachine create one, the other (the majority) are one with a physical display attached where I need to connect.
    At first I thought the switch DisplayServerExtraOptions “-nodamage” soled the problem but I was connecting on a node where there was no physical display.
    The problem explained:
    As soon as I use the switch  “no damage” on nodes with a physical display, I’m not able to connect to it, with the error <No available sessions on this server>on the client. If I disable the option, that’s working
    In a next message, as I have time to help you to track this I’ll send you my logs files.
    #11414
    Britgirl
    Keymaster

    Can you update to the latest version and see if the issue is still there?

Viewing 14 posts - 1 through 14 (of 14 total)

This topic was marked as solved, you can't post.