Display lock

Forums / NoMachine for Windows / Display lock

Tagged: ,

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #3102
    john2069
    Participant

    Using NoMachine Windows.

    When accessing the Linux machine the display locks very quickly if I’m not interacting.

    How can I set the display not to lock, or set a very long time?

    thanks

    John

    #3183
    graywolf
    Moderator

    Hello.

    There is no option in NoMachine to set the inactivity time out. It is a feature of the desktop environment, NoMachine is not supposed to change that value.

    Could you tell us how much quickly the display locks? After few seconds or what?

    Which Linux OS are you using? Gnome or KDE?

     

     

    #3190
    john2069
    Participant

    My desktop uses Win81, the Power Option is set to Turn off the display = Never when plugged in.

    The NoMachine window goes black at 5mins, requiring me to login again.

    The machine i connect to with NoMachine is RHEL 6.3, gnome.

    #3196
    graywolf
    Moderator

     

    My desktop uses Win81, the Power Option is set to Turn off the display = Never when plugged in.

    What about the desktop of Linux server you are accessing?

     

    The NoMachine window goes black at 5mins, requiring me to login again.

    Did you go to the Gnome screen saver setting to change the timeout value?

     

    • This reply was modified 7 years, 5 months ago by graywolf.
    #3221
    john2069
    Participant

    It alot of looking but found where to modify the gnome display timeout settings.

    Found and reset at /usr/bin/gnome-screensaver-preferences

    This fixes the issue for a default NoMachine install on RHEL 6.3 GNOME 2.82.2

     

    thanks

    John

    #3238
    Britgirl
    Keymaster

    I just wanted to add that NoMachine doesn’t set or add anything to your Linux environment. Anything related to your profile, a service or system setting, e.g. the screensaver in your case, doesn’t change because you installed NoMachine. So the fact your screensaver was activating itself after a very short time is not a bug of NoMachine. It was simply a setting in Gnome that had been configured incorrectly 😉

    Further references: https://www.nomachine.com/AR11K0074

     

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.