Do not change resolution on connect

Forums / NoMachine for Windows / Do not change resolution on connect

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #10193
    Avatargohanman2
    Participant

    When I connect to the server, the server’s screen resolution changes. I want it to stop doing that and just leave the server’s resolution as it is. Both client and server are running NoMachine 5 (free) on Windows 10. It’s a fresh install and I have not changed any of the defaults. I did look at the different Display options using the top-right peel menu but none of them seemed to help. The docs (https://www.nomachine.com/AR02M00835) imply that “Resize Remote Screen” should be off by default. I haven’t done anything on purpose to enable it, but I honestly can’t tell from the top-right peel menu what is and is not enabled – it just has big icons with no clear indication [at least to me] of whether or not they’re enabled. Clicking the “Resize Remote Screen” button repeatedly, which I would expect toggles the setting on and off, never restores the server to its original resolution though. When the client disconnects the server resolution does change back to the original value.

    Server resolution is 1024×768. Client resolution is 1366×768.

    #10199
    AvatarTor
    Contributor

    Hi.

    When you connect to the remote desktop, the resolution changes to match the client display configuration, in order to give you the best experience when working in fullscreen mode. This is the default behaviour and it can be changed in two ways: uncheck the box “Change the server resolution to match the client when I connect” visible in a panel while the client is connecting to the desktop, or if you miss that panel or asked the client to never show it, you can uncheck the box “Match the client resolution upon connecting” in the Display settings panel.

    #10204
    Avatargohanman2
    Participant

    Sorry for being obtuse, but can you post screenshots of what you’re talking about? I cannot find the first checkbox mentioned anywhere. The only prompt I get while connecting is for username and password.

    Once connected, the display panel I see is like the one pictured here https://www.nomachine.com/DT10K00060&dn=#5. There is a “Resize Remote Screen” icon but no checkbox. I cannot figure out what the icon is telling me about the state of the setting. If I click the icon once the server resolution does change, although not back to the original resolution, and nothing about the icon changes as far as I can see to show it’s state. If I click the icon again, the server resolution changes again, although not back to the original resolution, and nothing about the icon changes as far as I can see.

    Alternately, if there’s a config file where I can specify these rather than fighting with the GUI that would be great.

    #10212
    AvatarTor
    Contributor

    No problem, screenshots attached. You can see that welcome panel after authenticating to the server, when the desktop becomes usable. Probably the first time you saw it you’ve selected to never show it again.

    You can still configure it from the Display menu (where you see the “Resize remote screen” icon): click on “Change settings” then check the box you see in the second attached screenshot.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.