Does NoMachine support local USB device?

Forums / NoMachine for Windows / Does NoMachine support local USB device?

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #21412
    zhou_heng
    Participant

    Local: Windows 10 and NoMachine (don’t know how to check the version, but NoMachine updates itself often so it should be the latest).

    Remote: Ubuntu 16.04 64 bit.

    My question is: Does the USB device plugged into local Windows machine work in remote machine? For example, if I plug in a USB game controller, can the program running on remote Ubuntu (say, jstest-gtk) detect it? Thanks.

     

    #21424
    Giorgi-G.
    Contributor

    Hi,

    NoMachine supports USB devices forwarding and may allow to forward your USB game controller from your Windows machine to the remote Ubuntu. To do that you need to click on top right corner of screen, after NoMachine session menu will appear click to

    Devices -> Connect USB Device -> Find your game controller in list of Local Devices -> Click on it -> Click Connect.

    After device will be forwarded to remote machine you will see green dot near your device.

    Please have in mind that if you want game controller to work on remote Ubuntu you need to have installed drivers for it on Ubuntu.

    Additionally, if you will not see any devices in Devices -> Connect USB Device panel, it may sign that you have not builded nxusb.ko module n Ubuntu. To build it please follow this article AR12J00658

    #21696
    zhou_heng
    Participant

    Hi, Giorgi-G.:

    It does not work. There is a red ! below the icon of the game controller. Ubuntu does not respond to my game controller. But it works if I use the controller locally on the remote Ubuntu, indicating that the driver is installed properly.

    Now what?

    #21733
    Giorgi-G.
    Contributor

    Hi,

    Can you please send us logs from Windows machine (see https://www.nomachine.com/AR10K00697″) and screenshot of Devices -> Connect USB Device panel?

    And also try to forward another USB device, i.e. Flash Drive from your Windows to Ubuntu. Just do that after restart of both machines.

    #21771
    zhou_heng
    Participant

    The log file is in the attachment: log.zip, log.z01-z03

    The screenshot is attached at the bottom. The device titled “Microsoft Corp.” is the game controller I wanna connect.

    I tried other USB devices: my Android phone and the USB keyboard, but none of them can connect.

    There is no way to restart remote Ubuntu, because it is a node of my institute’s cluster.

    Please let me know whether you can receive these files and need more.

     

    #21780
    Giorgi-G.
    Contributor

    Hi,

    There are 3 possible reasons why it doesn’t work.

    1. USB forwarding kernel object is not compiled. Take a look here https://www.nomachine.com/AR12J00658

    2. Your Linux is running in Secure Boot mode, take a look here https://www.nomachine.com/AR05O00929

    3. On the remote Unix machine, the administrator has disabled USB forwarding/connecting to it and that’s why you can’t forward anything to Unix machine.

    #21790
    zhou_heng
    Participant

    1. How to check whether USB forwarding kernel object is compiled or not?

    2. How to check whether the remote Linux is running in Secure Boot mode?

    3. How to check whether the admin has disabled USB forwarding/connecting?

    I have read the link you gave, but cannot answer the above questions by myself.

    #21793
    Giorgi-G.
    Contributor

    Do you have root access to your remote Ubuntu?

    Without it you will not be able to check any of that 3 points and the only way is to talk with the administrator of that machine administrator. If you have it – you can just the follow links I sent in my previous post.

    #21838
    zhou_heng
    Participant

    I’m not admin so I don’t have root access. I contacted the admin. He said that he did not do anything special to the installation or configuration of NoMachine. Now what? Can you conduct an investigation of the software on your side?

    #21843
    Giorgi-G.
    Contributor

    Hi,

    In that case, I can explain the steps to follow for point #1. Here are instructions for how you can do that without admin rights:

    Connect to remote machine, open terminal on it and type command:

    cat /usr/NX/var/log/nxinstall.log | grep -i usb && ls -l /usr/NX/bin/drivers/

    After go to NM Menu -> Devices -> Connect a USB device and wait 10 seconds till devices appear and type this command in the terminal :

    lsmod | grep nxusb

    And send us file with all output from the terminal.

    Again, the above commands don’t need root access. And they will completely cover point #1.

    It also may be helpful if you send us the logs from remote Linux machine. Because of you don’t have root rights, you will not be able to send us a complete package. But partial logs will be possible.

    To collect them run following command in terminal:

    cd ~/ && tar -czf linux_log.tar.gz /usr/NX/var/log

    That command will report warnings, however don’t worry about them. A linux_log.tar.gz package will be created in your home directory. Send this file to us using forum[at]nomachine[dot]com making sure you reference your topic.

    #21852
    zhou_heng
    Participant

    Hi, Giorgi-G.:

    Thank you for the reply. This is the results returned from command cat /usr/NX/var/log/nxinstall.log | grep -i usb && ls -l /usr/NX/bin/drivers/:

    NX> 700 Running: /bin/chown root:root ‘/usr/NX/scripts/restricted/nxusb.sh’.
    NX> 700 Running: /bin/chmod 744 ‘/usr/NX/scripts/restricted/nxusb.sh’.
    NX> 700 Running: /bin/chmod u+s ‘/usr/NX/scripts/restricted/nxusb.sh’.
    NX> 700 Compiling the USB module.
    NX> 700 Running: /bin/cp -f ‘./nxusb.ko’ ‘/usr/NX/bin/drivers/’.
    NX> 700 Running: /usr/bin/strip –strip-debug /usr/NX/bin/drivers/nxusb.ko.
    total 76
    -rw-r–r– 1 root root 73776 Jan  9  2018 nxusb.ko

    The command lsmod | grep nxusb returns nothing.

    The log file (linux_log.tar.gz) generated by command cd ~/ && tar -czf linux_log.tar.gz /usr/NX/var/log was sent to the given email address. Please let me know if you need any other information. Thank you again.

    #21857
    Giorgi-G.
    Contributor

    The command lsmod | grep nxusb returns nothing.

    Are you sure that before running that command you opened Devices -> Connect USB devices and waited before USB devices list will be loaded?

    About logs – we didn’t receive anything to forum@.

    #21862
    zhou_heng
    Participant

    Yes, a circle is rotating. I waited until a red ! is marked on the USB icon. Then I ran lsmod | grep nxusb, but there is nothing returned.
    `

    #21863
    zhou_heng
    Participant

    I did send the log file to forum[at]nomachine[dot]com. I attached the log in this reply again. Hope you can get it.

    Attachments:
    #21871
    Giorgi-G.
    Contributor

    For now we can say that you have passed point #1. And the reason why USB device forwarding doesn’t work is that nxusb.ko driver is compiled but not loaded. So you will not be able to forward devices from it or connect devices to that machine.

     

    It’s necessary to check and find one of two possible reasons why it’s not loaded. To that you need to have a root access. And also to fix it you will need to have root access.

    Here are instructions to find out why driver is not loaded:

    Run in terminal following commands:

    sudo insmod /usr/NX/bin/drivers/nxusb.ko

    after:

    tail /var/log/syslog 

    and send us output from terminal.

Viewing 15 posts - 1 through 15 (of 15 total)

This topic was marked as solved, you can't post.