Doesn't work after installing new version 5.3.10_7

Forums / NoMachine for Linux / Doesn't work after installing new version 5.3.10_7

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #15569
    Avatardmanushin
    Participant

    Hello, i’ve just installed NoMachine for Linux 5.3.10_ 7 on Oracle 7.2 and it doesn’t work, connection aborted. from Linux side if i run /usr/NX/bin/nxserver i see next error

    /etc/NX/nxserver: /usr/NX/bin/nxserver.bin: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

    /etc/NX/nxserver: line 121: /usr/NX/bin/nxserver.bin: Success

    lib/ld-linux.so.2 is really doesn’t exist

    [root@MOSSPROD01 lib]# ls ld*

    ls: cannot access ld*: No such file or directory

     

    How can i fix this?

     

    thank you.

     

    #15572
    Avatarzaq
    Contributor

    Hello dmanushin,

    Looks like you have 64 bits (x86_64) operating system and you installed NoMachine package
    for 32 bits (i686). I expect that you use NoMachine Free, so I use this type of installation in
    my instruction.

    Firstly please uninstall current NoMachine package:

    sudo rpm -e nomachine

    remove leftowers:

    sudo rm -rf /usr/NX /etc/NX /var/NX

    Download the right package:

    https://www.nomachine.com/download/download&id=14

    install the new package:

    sudo rpm -i nomachine_5.3.10_6_x86_64.rpm

    Now you can use NoMachine.

    #15574
    Avatardmanushin
    Participant

    Holly cow, you are right… pardon and thank you!

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.