Domain User Single Sign On login Error

Forums / NoMachine for Linux / Domain User Single Sign On login Error

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #38344
    favorite1
    Participant

    Hello,

    Virtual Machine (Pardus-XFCE Debian base)

    NoMachine Version : nomachine_6.12.3_7_amd64.deb

    Client NoMachine Version : nomachine_7.9.2_amd64

    In the scenario and version I mentioned above, I can login to the machine with a single password, but server.cfg
    DisplayOwner ‘$User’
    DisplayCreate 1
    When I set options, I can log in Single Sign On. No problem with this version, it works for me.

    In the same scenario, the new version nx version Single Sign On login does not work for me, can you help me with this? What is the difference between 6.12.3.7-amd4 and 7.9.2.1-amd64?

    In short, we do not want to login to both the NoMachine screen and the operating system, we just want to login to the NoMachine screen and log in to the machine.

    #38358
    Bilbotine
    Keymaster

    Hello favorite1,

    We need to investigate further to be able to help you.

    Please enable debug log level as explained here: https://knowledgebase.nomachine.com/DT11R00182

    Once done, reproduce the problem, collect the logs and send them to forum[at]nomachine[dot]com, with the topic as reference in the subject field.

    Thanks!

    #38367
    favorite1
    Participant

    hi Bilbotine
    thank you for your help.

    OS ;
    Linux 4.19.0-17-amd64 #1 SMP Debian 4.19.194-3 (2021-07-18) x86_64 GNU/Linux

    I have collected the logs, the list is below;

    v7.9.2 Log
    v6.12.3_7 Log
    Client v7.9.2 Log

    I discovered something. In v6.13, there is a folder called running under /usr/NX/var/db/ and it records the screens there instantly.

    This folder does not exist in v7.9.2.

    I will be very happy if we can solve this problem.
    I am sharing the logs in the attachment with my best regards.

    #38391
    brotech
    Participant

    Hello favorite1,

    Your logs from version 6 and version 7 show the different behaviours of the two versions: Nxserver v6 was not able to find a physical session, so its started a frame buffer session.
    In the case of V7, you have access to the normal physical session, and there is no reason for NoMachine to start a frame buffer session.

    To have the same behaviour as you had with V6, you have a wide range of possibilities, as you can configure your desktop manager to automatically log you in to the physical desktop – or disable the desktop manager at all.

    You can also set the PhysicalDisplays key to value “:900” in the node configuration file, to make sure that the nxserver will not be able to find a physical desktop. It will then start a frame buffer session as it does in V6.

    Regards

    #38424
    favorite1
    Participant

    Hi Brotech.

    it didn’t work for me in these two options v6 works fine for me but 7 is not like that. What else would you recommend for me..

    #38468
    brotech
    Participant

    Hello favorite!

    did you try the last one as set key PhysicalDisplays to value “:900” in /usr/NX/etc/node.cfg on server,
    and then restart it (sudo /etc/NX/nxserver –restart) ?

    Please share new logs, config files if you modified them also.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.