Double NAT – Remote through Internet

Forums / General Discussions / Double NAT – Remote through Internet

  • This topic has 1 reply, 2 voices, and was last updated 3 years ago by Avatarkroy.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #18318
    Avatartestr
    Participant

    Hi,

    I have seen few topics already on the issue of configuring double NAT environments for NoMachine. But still have not found solution in connecting through internet so creating a new topic. Thanks in advance!

    My environment has two routers both DHCP running. Router A (192.168.1.X) has WAN port has non-static IP (122.170.23.XX) from ISP. and Router B (172.16.0.X) has WAN IP of (192.168.1.2). Both routers have UPnP enabled.

    On NoMachine client’s welcome screen I see local IP (172.16.0.10:20200) and external IP (192.168.1.2:20200). Why am I not getting my ISP provided IP (122.170.23.X) from Router A?

    I have done port forwarding on Router A to Router B’s IP for all ports (20400, 4000, 22, 4022). I do see on Router B’s UPnP table port correctly mapped to my local IPs. I can connect fine locally.

    I am running the below:

    NoMachine Free Client – 6.1.6, Mac OS High Sierra: 10.13.4, Router A (DLink DSL224), Router B (Binatone WR3005N3)

    Please let me know what I can do in terms of configuration/debugging to get this working remotely.

    Thanks,

    #18367
    Avatarkroy
    Contributor

    I have done port forwarding on Router A to Router B’s IP for all ports (20400, 4000, 22, 4022).

    It’s not necessary to forward all ports. I can suggest to undo all your changes.

    Please check if UPnP is enabled on the router B. On the router A add port forwarding: port 20200 to the router B IP (in your case: 192.168.1.2).

    When connecting to the NoMachine Server using for example NoMachine Player, provide external IP, in your case 122.170.23.X and as a Port set the one opened on router A – 20200.

    Please also check all firewalls that may be enabled/running on each router and servers involved. If you will still cannot connect to NoMachine Server I would suggest to disable them all and try again.

    In Local network – LAN A connected to router A – you should be able to connect to NoMachine Server inside LAN B – connected to router B using IP: 192.168.1.2 and port 20200. If you still cannot connect [ 192.168.1.2 and port 20200 ] in that scenario, that could be reason of not working/disabled UPnP or something blocking connection – like firewall.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.