Dragging window very slow and random freezes on RPi4

Forums / NoMachine for Raspberry Pi / Dragging window very slow and random freezes on RPi4

Tagged: 

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #31094
    AvatarBrevan960
    Participant

    I have a Raspberry PI 4 and when I try to connect to a pc I get really bad performance I’ve tried to disable multi-pass display encoding and have tired disable frame buffering on decoding and disable client-side image post-processing and have tired different encoding option (VP8, H264, MJPEG) and I don’t know what to try next

    I’ve even tried overclocking the pi and running both 32bit and 64-bit Raspberry PIOS.

    The type of lag I’m getting is: when I drag a window it takes a very long time to show the changes and just freezes for like 1-2 seconds at random times and massive v-sync issues

    As stated before I’m using a Raspberry PI 4 with an ethernet connection and I’m connecting to a macOS Host and when i connect to it using a different pc it works fine

    Any help is appreciated,

    Thanks.

    #31258
    AvatarBritgirl
    Keymaster

    Hi, RPi4 as a desktop client most likely is not the best choice. If you’re using it to run a Youtube video, for example, with Raspbian’s own Chromium, CPU usage can reach 100%.  Whereas if you use a PC to connect, there are no issues whatsoever. We are planning to support GPU accelerated decoding on RPi in the future, so watch out for that.

    Adding support for GPU accelerated H.264 hardware decoding on Raspberry devices
    https://www.nomachine.com/FR10R04038

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.