DSA key in iOS

Forums / General Discussions / DSA key in iOS

Tagged: 

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #6669
    slane
    Participant

    This question was asked earlier (#4537): How can I import the DSA key? NoMachine 4.4.12 for iOS provides a feature to allow loading the key from a file, but I can’t navigate to any directory in which I could place the key. The reply to this earlier question (item #4539) was “This problem has been fixed; the updated version will be available soon. Keep watching this space.” However, I cannot find any published instructions on how this “fix” is implemented.

    I’m running iOS 8.2, attempting to connect to a server running on a Linux machine (CentOS 6.6). Connections work fine from NoMachine OS X client.

    #6752
    Tor
    Contributor

    Hi slane.

    Our application is configured to share files with the connected computer through iTunes. Once the device is connected, open iTunes, select your device, enter Apps tab, on the left select NoMachine then click the ‘Add…’ button.

    When the file is ready create a new connection in NoMachine App, select “Private key” then in the next wizard page you can browse the file system that, by default, starts from the same directory where the file was added with steps listed above.

    #7251
    slane
    Participant

    Thanks for the reply, and sorry for the long delay in trying this. The above worked perfectly, once I figured it out that I had to go to the “File Sharing” section instead of just selecting the first NoMachine icon presented in iTunes. I would simply clarify the instructions as follows, at least for those connecting the iOS device to a Mac through iTunes:

    Open iTunes, select your device, click on the Apps item on the left, then navigate to the “File Sharing” section at the bottom of the page. Select the NoMachine icon, then click the `Add…’ button. Navigate to the location of your key file and select. This will add the file to the file structure on the iPad. (I found mine under the Documents folder that was offered when I browsed the file system as described above.)

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.