Empty USB device list

Forums / NoMachine for Mac / Empty USB device list

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #35230
    jeremy.fix
    Participant

    Hello everyone,

    I’m facing an issue with NoMachine client on MacOS 11.4 (the server running on an ubuntu 20.04); When I want to share a USB device, the list is empty while a Logitech joypad was plugged in.

    That’s an issue I’m used to solve on Linux where I usually have to recompile nxusb.ko (as given here : https://tutos.metz.centralesupelec.fr/TPs/NoMachine/index.html#when-it-fails) but unfortunately, I do know about the procedure on a MacOS client ; I wandered around, unsuccessfully, in the /Applications folder.

    Can anyone provde me some track to follow to solve this issue ? I do not know if this might be related to some other posts (such as the one on kext : https://forums.nomachine.com/topic/nomachine-for-mac-does-not-install-usb-kext)

    Thank you for your help.

    #35237
    Giorgi-G.
    Contributor

    Hi,

    Please look at this article to:

    How to enable USB devices forwarding on macOSX
    https://knowledgebase.nomachine.com/AR01P00962

    #35245
    jeremy.fix
    Participant

    Hi, Thank you for this feedback which worked for one user running Mac OS 10.14 (For sure that was a 10.xx not sure about the 14); For this user, as soon as sharing the device was selected in NoMachine, the security app of MacOS poped up and we were able to accept the use of the extension

    But, unfortunately, that did not work for 2 or 3 users that were running a 11.x MacOS. As far as I remember, there was a 11.5.2, a 11.4, and another.

    For example, for the 11.5.2 user, you see on the screenshot attached to this message that the device list is empty and nothing appears on the “Security and confidentiality” where I would have expected to see something about the nomachine extension. The user tried to uninstall and reinstall NoMachine expecting the message to appear again but unfortunately not.

    Do you have another suggestion on the way to proceed ?

    #35255
    Britgirl
    Keymaster

    Can you submit your image to forum[at]nomachine[dot]com? The forums administrator can then add it here for you 🙂

    #35383
    Giorgi-G.
    Contributor

    Hi,

    Please run this command in the terminal

    ls -l /Library/Application\ Support/NoMachine/Extensions/ | grep nxusb

    If the output is empty, the patch we sent you yesterday should fix it.

    #35390
    jeremy.fix
    Participant

    I’m unable to test your command because I do not possess the computer.

    But indeed, the script you sent me yesterday solved the problem. I will answer the result on the other original thread.

    Thank you for your help.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.