Enable guest access to NoMachine Terminal Server Node

Forums / NoMachine Cloud Server Products / Enable guest access to NoMachine Terminal Server Node

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #5895
    Avatarjoe.gly
    Participant

    I am setting a POC with NoMachine Enterprise Server Evaluation – Version 4.4.1 and NoMachine Terminal Server Node Evaluation – Version 4.4.1.

    Single server with Enterprise Server and a single node with Terminal Server Node installed.

    I am able to connect to the node from a windows client using a manually created account but if I try to connect as guest, I get the error “The session negotiation failed. Error: No nodes available for user’s profile”

    I have run the command nxserver –ruleadd –class feature –type enable-guest –value yes on the server. What else needs to be done?

    #5915
    Avatarjoe.gly
    Participant

    ~Adding logs

    Attachments:
    #5949
    AvatarHaven
    Contributor

    Hello joe.gly,
    We have identified the issue and have opened a Trouble Report:
    https://www.nomachine.com/TR01M04838
    Please also check the latest release. A patch was included.

    #5954
    Avatarjoe.gly
    Participant

    The guests are not being created automatically on the nodes even after the update

    #5991
    AvatarHaven
    Contributor

    Hello joe.gly,
    We have identified this issue and have opened a Trouble Report:
    https://www.nomachine.com/TR01M04875

    As a temporary workaround please remove your remote node and add it again:

    /etc/NX/nxserver --nodedel <remote node>
    /etc/NX/nxserver --nodeadd <remote node>
    #5992
    Avatarjoe.gly
    Participant

    Guest accounts are being created automatically after re-adding the node. Thank you

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.