Enable Session Shadowing on iMac

Forums / NoMachine for Mac / Enable Session Shadowing on iMac

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #6237

    I was using NoMachine version 4.4.6 on my imac and suddenly it could not connect and the error said “Session Shadowing Disabled on this Server”. I also have NX installed on my macbookpro and I am able to connect to the session. I am clueless regarding what exactly the issue might be, do I have to change any settings on my macbookpro for me to access the session on my imac? I dont mind deleting all the NX stuff from my macbook but not at all what is the root problem for this. Also, is there an easy way to enable session shadowing via NX GUI. I have attached a screenshot of the error window.


    hello ravikanthuppu,
    Please check the following keys:


    in file:

    Both keys should be enabled to provide access to physical session.


    Hi Haven,

    Thanks for the reply. However both the keys are enabled on my Imac as well as macbookpro. Am I missing something?

    I have read that I need to change EnableSessionShadowing to 1, which I dont see on either of the systems.

    Thanks Again.



    Hello Ravi,
    We will need debug NoMachine server logs to investigate further. Please follow the instructions here:
    Send them to issues[at]nomachine[dot]com

    After enable debug logs on problematic machine please execute:
    /etc/NX/nxserver --restart
    and after that try to reproduce the issue.

    Additionally please provide files from the server machine:

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.