Enabling 2FA prevents access to secured server configs in the GUI

Forums / NoMachine for Linux / Enabling 2FA prevents access to secured server configs in the GUI

Tagged: ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #39862
    Azzip
    Participant

    Hi there,

    I am using NoMachine 7.10.1 with Kubuntu 22.04.01 on several fresh OS setups and computers. On all of those systems, I can reproduce the following problem:

    After adding “auth required pam_google_authenticator.so” to the file /etc/pam.d/nx (which successfully finalizes the 2FA configuration) I can no longer enable changing secure server settings in the GUI. This is independent of any remote connection.

    Clicking on “Changes disabled” triggers a password prompt as usual. However, entering the correct password yields no error message (as opposed to entering a wrong password) and does not enable changing the secure settings. Instead, the GUI freezes and does not allow any menu input.

    After commenting out the “auth required…” line in /etc/pam.d/nx and restarting the Nomachine GUI (via Quit NoMachine Player), I can access the secured settings again (i.e. clicking “Changes disabled” turns to “Changes enabled” after password entry).

    Of course I can still change settings by editing the config files directly or by temporarily disabling 2FA. But I would like to know if anyone else has encountered this problem and found a better solution than that.

    Thank you and kind regards

    #39866
    Britgirl
    Keymaster

    Hi,

    thanks for taking the time to report this. The GUI preference changes don’t currently support pam_google_authenticator but we will be adding it in one of the next releases. In the meantime you can continue to edit the CFG files as you have already been doing.

    #39867
    Azzip
    Participant

    Roger that, thank you for the swift response!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.