Enabling SSH on server

Forums / NoMachine Cloud Server Products / Enabling SSH on server

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #6039
    venkats
    Participant

    When I try to connect to an NX server using ssh (which is a workstation edition) the client says “Running NoMachine over a ssh connection is disabled on this server…..”. How I enable NX to use ssh on the server?

    #6053
    hawk
    Participant

    Hello,

    did you install the Workstation from scratch or was it an update?

    Please tell me also operating system and version of the machine
    where the Workstation is installed (e.g. Ubuntu 14.04).

    Additionally, provide the nxinstall.log file.
    It’s in the /usr/NX/var/log/ directory.

    #6214
    venkats
    Participant

    It was an install from scratch, but after uninstalling a prior trial version. Attached are the install logs.

    #6223
    Britgirl
    Participant

    Please send the logs to forum[at]nomachine[dot]com

    #6469
    venkats
    Participant

    I have sent the logs to forum[at]nomachine[dot]com

    #6503
    hawk
    Participant

    After NoMachine uninstall, configuration files are backed up and left in /usr/NX/ directory. When you installed NoMachine Workstation, configuration files from NoMachine free were restored. NoMachine free does not support SSH, so the two keys controlling the use of SSH now need to be set by hand. You have do add SSH value to the ClientConnectionMethods key in server.cfg and to ClientConnectionMethods in node.cfg.

     

    #6521
    venkats
    Participant

    Is there evidence of that in the logs? I had a trail edition of the NoMachine Workstation (not NoMachine free) before this and ssh was working. Then I uninstalled NoMachine and also renamed /usr/NX to /usr/NX_old to avoid the issue you refer to.

     

     

    #6522
    venkats
    Participant

    Looks like ssh is already there int the Client Connecttion Methods.

    XPS8700: ~ : sudo grep -i ssh /usr/NX/etc/server.cfg

    # SSH:  Redirect port of the SSH server.

    # none: Do not redirect port. Connections via NX, SSH or HTTP

    # Specify the port where the SSHD service will be redirected using

    #SSHDUPnPPort “”

    # Specify the TCP port where the SSHD daemon is listening on the NX

    #SSHDPort 22

    # from local DB or through SSHD authentication, can connect to the NX

    # system. This is likely to be the default when SSHD authentication

    # 0: Disabled. Use SSHD + PAM authentication.

    # word will be verified against the current PAM settings by the SSHD

    # user being authenticated by SSHD account will be enabled to connect

    # Specify hostname of the server used for NX SSH authentication.

    #SSHDAuthServer 127.0.0.1

    # Specify the TCP port where the SSHD daemon is running on the NX SSH

    #SSHDAuthPort 22

    # the SSH server will be started automatically at every reboot.

    # 1: Automatic. Enable automatic starting of the SSH server.

    # 0: Manual. Disable automatic starting of the SSH server.

    #StartSSHDaemon Automatic

    # comma-separated list. Supported methods are: NX, SSH and HTTP.

    ClientConnectionMethods NX, SSH

    # Specify the location and name of the SSH authorized keys file.

    SSHAuthorizedKeys authorized_keys

    # Accept or refuse the client connection if SSHD does not export

    # the ‘SSH_CONNECTION’ and ‘SSH_CLIENT’ variables in the environment

    #SSHDCheckIP 0

    # Specify path to the SSH client.

    #SSHClient /usr/bin/ssh

     

     

     

     

    XPS8700: ~ : sudo grep -i ssh /usr/NX/etc/node.cfg

    # comma-separated list. Supported methods are: NX and SSH.

    ClientConnectionMethods NX,SSH

    # Specify the location and name of the SSH authorized keys file.

    #SSHAuthorizedKeys $(HOME)/.ssh/authorized_keys2

    #6587
    hawk
    Participant

    The reason why SSH sessions are disabled is still unclear and we would need some additional information to continue this investigation.

    Can you please send us whole compressed /usr/NX/var/log/ directory and your server.cfg file from /usr/NX/etc/ ?

    Send them to forum[at]nomachine[dot]com, thank you in advance.

    #6720
    venkats
    Participant

    I have emailed the logs. Could me send me instructions to uninstall and try this again. Note that I have the paid version so please send instructions on how to activate the key too.

    #6726
    Britgirl
    Participant

    The logs will be looked at. If you have a Workstation, you should have received instructions in the email that is issued with your licenses attached. There is also an article linked from within the email. Please consult:

    How to activate licenses for NoMachine 4
    https://www.nomachine.com/AR09K00687

    #6789
    venkats
    Participant

    Hello Hawk,

    You have any updates for this?

    Thanks,

    Venkat

     

     

    #6884
    hawk
    Participant

    Hello venkats,

    I’ve noticed that there is a space between ‘,’ and ‘SSH’ in your ClientConnectionMethods key:

    ClientConnectionMethods NX, SSH

    Please remove this space and restart nxserver by terminal command ‘sudo /etc/NX/nxserver –restart’.

    It should look like this:

    ClientConnectionMethods NX,SSH

Viewing 13 posts - 1 through 13 (of 13 total)

This topic was marked as solved, you can't post.