Enterprise Desktop unable to start http after installation

Forums / NoMachine Cloud Server Products / Enterprise Desktop unable to start http after installation

This topic contains 3 replies, has 2 voices, and was last updated by Avatar oolmedo 8 months, 3 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #20611
    Avatar
    oolmedo
    Participant

    Hello,

    I have installed NoMachine Enterprise Desktop for evaluation in Ubuntu Desktop 18.10, after installation (debian packages), from GUI, I see that the HTTP service network (4080) and HTTPS didnt start (I was unable to access the desktop from client browser).

    Trying to start the service manually, from GUI (didnt start), I saw the following error in /usr/NX/var/log/nxserver.log:  ‘NX> 500 ERROR: Support for HTTP server is not permitted on this server. Googling in this forum, I found that ClientConnectionMethods entry in the /var/NX/etc/server.cfg had to be modified to NX,SSH,HTTP.

    After doing this change, I receive the following error when again, I tried to start http service from GUI in the nxserver.log: ‘NX> 500 ERROR: Cannot start service: nxhtd.’.

    I send in attach the nxserver.log (the part of this file when I tryied to start manually the service http from GUI)

     

    Thanks and best regards

     

    Osvaldo

     

    #20626
    Avatar
    kroy
    Contributor

    Is it possible that you installed NoMachine Enterprise Desktop on the machine where your previously had NoMachine free installed? During installation the new package doesn’t overwrite old config and license files, so please try uninstalling NoMachine and removing the whole /usr/NX directory. Then install NoMachine Enterprise Desktop again.

    #20631
    Avatar
    oolmedo
    Participant

    Hello Kroy,

    Thanks for your reply. Yes, you were right, I had previously installed NoMachine free, although I remove the packages I didn’t delete the /usr/NX directory. I will do that.

    Thanks for your help

    Best regards

     

    #20632
    Avatar
    oolmedo
    Participant

    Hi Kroy,

    After removing the /usr/NX directory, I install the pkgs, everything is fine now. I am accessing the desktop without problems.

    Thanks for your advice, best regards

    Osvaldo

     

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.