Error 138 – Can’t connect to office computer from home

Forums / NoMachine for Windows / Error 138 – Can’t connect to office computer from home

This topic contains 10 replies, has 3 voices, and was last updated by Avatar leekaster 3 years, 7 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #9751
    Avatar
    leekaster
    Participant

    I’m trying to connect to my desktop PC at my office from my laptop at home. I’m using NoMachine ver. 5.0.63. The laptop is running Windows 10 and the desktop PC is running Windows 7. The desktop machine is connected to the Internet through a router which I suspect may be the problem. I tried entering in all three IP addresses that the welcome window on the desktop machine lists but each time I get “Error is 138: Connection timed out.” I believe I have saved the relevant log files and can send them to someone willing to look. Thanks

    Lee

    #9779
    Avatar
    kroy
    Contributor

    Hi Lee.

    Are you sure that you are using correct IP and Port number? If you have installed NoMachine free version on the server – you should enter information from last position with IP and Port list on “welcome window”. It’s your external IP. Also make sure that your router (from server side) supports UPnP or NAT-PMP and that the option is enabled. There is an article with instructions on how to connect to NoMachine when the server is behind a NAT router or a firewall https://www.nomachine.com/AR11L00827.

    If your router does not support UPnP or NAT-PMP, it has to be configured manually to pass traffic to port 4000 (NX protocol) or (4022) (SSH protocol on Windows).

    #9795
    Avatar
    leekaster
    Participant

    Hi kroy–

    Thanks for the response. Yes, I entered in the IP addresses and port numbers listed in the Welcome screen. It lists three of them and I tried them all. And I confirmed that my router has UPnP enabled. Not sure it matters, but I am in a small office and accessing the internet on the server side via a Marvell ethernet controller that I share with several other users. The internet service provider is AT&T. My computer repair person mentioned the problem may be that I don’t a static IP address. I have no idea, that is past my level of sophistication when it comes to computers.

    #9806
    Avatar
    kroy
    Contributor

    Please try port forwarding. Configure your router manually to pass traffic to port 4000 (NX protocol) or (4022) (SSH protocol on Windows).

    #9908
    Avatar
    leekaster
    Participant

    I turned on port forwarding for port 4000 in my router settings but the IP address it’s forwarding to is a private IP address within my office network. I found my public IP address and tried using that but it also didn’t work. I am accessing the internet through a local network. I can send you a network map if you think that might help. Thanks

    Attachments:
    1. screen-shot.docx
    #9931
    Avatar
    kroy
    Contributor

    Are you sure that you have reserved local IP for your machine? Maybe you have dynamic IP and it has changed?

    Can you attach here a screenshot of the ‘Welcome screen’ that is shown when you open the player on the machine you want to connect to (server side)? To avoid showing sensitive information, blot out the numbers and leave showing the first two e.g. nx://80.170.X.X:26XX.

    Then check what is your public IP (you can check it by entering passphrase “my ip” in webbrowser). Is it the same?

    #9941
    Avatar
    leekaster
    Participant

    The screen shot is attached. No, the external IP address listed on the Welcome screen is not the same as my public IP address. I’m fairly certain I do have dynamic IP.

    #9954
    Avatar
    Britgirl
    Keymaster

    Seems the image was too heavy. We’ve sent you an email. Just reply to that and attach the image. Thanks.

    #9967
    Avatar
    leekaster
    Participant

    I just did. Thanks

    #10018
    Avatar
    Britgirl
    Keymaster

    You have two routers, and since you don’t control them, this makes things more difficult. You would need to contact the administrator to open the necessary ports to get access to the office network from home. The easiest option for you is to wait for NoMachine Network which will eliminate this problem altogether. You won’t need to know the IP address of your computer or worry about which router you have.

    #10025
    Avatar
    leekaster
    Participant

    Ok thanks. I appreciate the help.

Viewing 11 posts - 1 through 11 (of 11 total)

This topic was marked as solved, you can't post.