Error 60: Connection Timed out

Forums / NoMachine for Linux / Error 60: Connection Timed out

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #18874
    Avatarvivekuunni
    Participant

    I was trying to connect remotely to a ubuntu 14.04.5 LTS workstation from a Mac OS High Sierra 10.13.4.

    The work station is having a wired internet connection.It was getting connected when I was in the same local network.But the following error shows up when I try to connect it with the MacBook connected to wifi network

    Could not connect to the server.

    Error is 60: Operation timed out

    I am using version 6.2.4 of NoMachine in my MacBook and in the ubuntu (free versions both).The desktop of ubuntu is GNOME environment.

    I am attaching log files of the error.

    Thank you

    #18883
    AvatarBritgirl
    Keymaster

    The logs you tried to send didn’t attach. Try sending them direct to forum[at]nomachine[dot]com.

    #18907
    Avatarvivekuunni
    Participant

    I have sent the logs for error 60(connection timed out) to forum[at]nomachine[dot]com

    The ‘connection’ file is zero bytes for some reason.

    I am not able to ssh also from a different network. I can do it from the same network.

    #18923
    Avatarvivekuunni
    Participant

    I could figure out the problem.The firewall was blocking the access. I removed the firewall from the required port and I can connect now even from outside network.

    Thank you very much

    #18925
    AvatarBritgirl
    Keymaster

    From the logs we can see it was a network issue.

    When the NoMachine (server) computer is behind a NAT router or a firewall, NoMachine tries to use the UPnP or NAT-PMP protocol (depending on what is supported by the router) to:

     

    – Retrieve the public or external IP of the host machine where it’s installed.

     

    – Configure the router to allow a NoMachine client to connect from outside of the private network.

    Further reading:

    How to connect to NoMachine when the server is behind a NAT router or a firewall
    https://www.nomachine.com/AR11L00827

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.