Error: Cannot authenticate to the requested node

Forums / NoMachine for Linux / Error: Cannot authenticate to the requested node

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #32687
    Avatarjkissane
    Participant

    I’ve been trying to use NoMachine to allow remote connections to a PC running Fedora 33. I’ve run into an authentication problem that I’ve found lots of mention about online but no fix.

    The PC uses NIS to authenticate & I can ssh onto it without issues. An attempt to connect via NX gives these messages in the server log file:

    1888 1888 2021-04-01 09:49:12 650.050 NXSERVER WARNING! User john.kissane doesn’t exist in system.
    1888 1888 2021-04-01 09:49:12 650.195 NXSERVER WARNING! NXLogin: Cannot retrieve absolute username for user: john.kissane.

    & this on the client:
    The session negotiation failed.
    Error: Cannot authenticate to the requested node.
    Latest version of NoMachine on the PC (7.4.1_1) & I’ve tried from both Windows & Linux clients. We have a few licensed versions of NoMachine also working fine on Redhat servers using the same NIS domain etc.

    As part of troubleshooting, I found it does work if I create a local user on the PC so appears to be something in the interaction between NX & NIS but only on Fedora 33 (& possible other version).

    Any suggestions on how to proceed are very welcome as adding local users isn’t a viable solution.

     

    #32704
    AvatarCato
    Contributor

    Hello jkissane,

    The errors mean that passwd structure describing the user account can’t be obtained for user “john.kissane”. This is usually caused by missing entries specifying user data source in /etc/nsswitch.conf. To make sure that your system is correctly configured, please run the following commands from terminal as root user on your NoMachine Server host:

    getent passwd john.kissane
    getent group john.kissane

    Do they produce correct outputs?

    #32711
    Avatarjkissane
    Participant

    Thanks for the suggestion.

    “getent passwd” produces the entry in the yppasswd file, “getent group” produces nothing but then there is no group called john.kissane.

    As mentioned I can either ssh onto this box or login via window manager on the local screen without any errors.

    #32768
    Avatarjkissane
    Participant

    I just tried this on a new server running the latest version of RedHat (Red Hat Enterprise Linux release 8.3) & the same issue appears. An older version of NoMachine is working normally on some older versions of RedHat with the same setup.

    Not working – NoMachine-7.4.1-1.x86_64 on RHEL 8.3

    Working – NoMachine-5.0.47-1.x86_64 on RHEL 6.9

    Both using the same NIS domain/server.

    #32875
    Avatarjkissane
    Participant

    I reinstalled the PC with Fedora 25 as more important to the user is to be able to access it remotely than to have the latest & greatest. NoMachine (7.1.3) is working fine on that version. I don’t have the time to see where NoMachine stops working on the various Fedora versions between 26 & 33.

    #32989
    AvatarCarin
    Participant

    Hi jkissane,

    we were not able to reproduce the problem in our labs. It seems more like a configuration problem on your server.

    #32991
    Avatarjkissane
    Participant

    Thanks for the update, as I mentioned I installed Fedora 25 instead & all works fine with NIS configuration as before. When you say “configuration problem on your server” what exactly does that mean?

    This combination works:
    [root]# rpm -q NoMachine
    NoMachine-7.1.3-1.x86_64
    [root]# cat /etc/redhat-release
    Fedora release 25 (Twenty Five)

    Also doesn’t work under RHEL 8.3 so I suspect if the group who own those servers chose to purchase NoMachine licenses then I’ll be opening a support ticket at that stage.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.