Error is 138: Connection timed out

Forums / NoMachine for Linux / Error is 138: Connection timed out

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #5157
    PPG2014
    Participant

    Good day, I need help to connect NoMachine.

    I’m using the NoMachine Server 4.2.27 with Ubuntu Linux 4.2.24 and NoMachine Client with Windows 8.1.

    I am running this service for remote access Virtual Machines with Virtual Box (NAT mode). The IP address is 10.0.2.15 Windows and Ubuntu is 10.0.4.15. When I try to connect through WINDOWS Ubuntu, the following message appears: Error 138 connection timed out. The firewall is turned off on WINDOWS and port 4000 is released in the Rules of Entry and Exit, TCP and UDP.

    #5175
    Britgirl
    Keymaster

    Right now routers supporting UPnP or NAT-PMP are configured automatically to pass connections to NoMachine and all required information is displayed at initial screen (Welcome to NoMachine).

    Routers not supporting UPnP or NAT-PMP and Firewalls have to be configured manually to pass traffic to port 4000 (NX protocol), 22 (SSH protocol on Linux/MacOSX) or (4022) (SSH protocol on Windows).

    Additionally, your NAT service is running on Virtual Box which means that it cannot be configured automatically with help of UPnP or NAT-PMP. To do it manually please refer to: https://www.virtualbox.org/manual/ch06.html#natforward

    #5203
    PPG2014
    Participant

    I did the recommended setting, but the same error still persists!

    #5263
    Zenfer
    Participant

    Hello
    Your port forwarding settings should look like on the image attached.
    You can choose any host port that is not in use and you don’t have to specify IP.
    Bear in mind that you have to edit standard ports of NoMachine session in NoMachine Player (4000 and 22) to the ones specified in virtualbox NAT

    Regards

    #5356
    PPG2014
    Participant

    Zenfer, thank you for the help!

    #5357
    PPG2014
    Participant

    I made the recommended settings, and now the error is: error is 111 connection refused.

    Someone help me please!

    #5405
    Britgirl
    Keymaster

    Hello,

    Can you submit a screenshot and your session configuration file, so we can check what you’ve configured? You can submit them to issues[at]nomachine[dot]com for privacy reasons. Make sure you reference your email with topic title.

    #5447
    PPG2014
    Participant

    Hello Britgirl,

    The files are attached.

    Thank you

    #5476
    nars
    Contributor

    Hello PPG2014,

    In NoMachine player you should change the protocol and port of connection by right clicking on it and choosing “edit connection”, then specify correct preferences as you see in the attached image.

     

    Regards.

    #5489
    PPG2014
    Participant

    Hello Nars,

    I did this setup on NoMachine client, but the error persists.

    What setting might be wrong? Please help me.

    #5500
    nars
    Contributor

    We suspect that you are trying to connect using virtual machine IP.

    You should try to connect to IP of the machine on which Virtual Box VM is running. Use the correct port which was forwarded to the VM you are trying to connect to.

     

    Regards.

     

    #5503
    PPG2014
    Participant

    Hello,

    I’m struggling to know what this IP is.

    The eth1 interface IP (NAT) of the NoMachine server is 10.0.2.15

    how should I do?

    thank you

    #5529
    nars
    Contributor

    Hello PPG2014,

    You are trying to connect from host with IP “A” to virtual machine where is installed NoMachine server with IP “C” (10.0.2.15).

    Virtual machine is running via VirtualBox software running on host with IP “B”. You should try to connect to IP “B”, it will redirect you to Virtual Machine “C” because of port forwarding.

    Regards.

Viewing 13 posts - 1 through 13 (of 13 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.