Error: No available sessions on this server

Forums / NoMachine for Windows / Error: No available sessions on this server

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1982
    Avatardawsonfi
    Participant

    I’m trying to connect to a NoMachine server installed on a Windows 7 Desktop machine, but when i connect, my client (linux ubuntu 64 desktop) says that there is not available sessions on the server.

    In the server instance, i got the following error:

     

    11:19:13:058.066 NXSERVER-4.0.369[2572] User ‘touch’ logged in from ‘192.168.1.83’.

    11:19:46:884.596 NXSERVER-4.0.369[2572] ERROR: NXSelector: trying to add empty descriptor from (NXShell, (eval 80), 55, NXNodeExec::__send_request_to_node_and_wait).

    I’m using the last version on both machines.

    Anyone know how to solve this problem?

    Thanks

    #2588
    AvatarBritgirl
    Keymaster

    We released version 4.1 which solved a number of issues. Can you install this version and let us know if the problem is fixed?

    #2768
    AvatarCBruce
    Participant

    An FYI for dawsonfi … I just downloaded NoMachine Free Version at home and have been trying it out with my machines here:

    I run VMware Workstation on my XP-Pro-64 desktop – and I was able to launch NoMachine remote sessions between the desktop and an XP-Pro-32 VM.

    But I got the “No Available sessions on this server” error trying to connect to a Windows 7 laptop and an XP-Pro-32 laptop from my desktop machine.  I also noticed that the NoMachine monitor icon was not available in the System Tray on the laptops.

    In my case, I believe the problem occurred because I had installed NoMachine remotely on the laptops from inside RDP sessions.

    I logged in locally on the laptops – uninstalled NoMachine – then reinstalled NoMachine … and I am now able to launch remote sessions to both of them … and their NoMachine monitor icon is in the tray where it belongs.

    Hope it helps – CBruce

    #2785
    AvatarBritgirl
    Keymaster

    @CBruce, we weren’t able to reproduce this. Can you send us the logs? Follow the instructions here: https://www.nomachine.com/AR07K00677

    Reproduce the issue once you’ve enabled them, zip them up and attach here. Or alternatively, send them to issues[at]nomachine[dot].com

     

    #2952
    AvatarCBruce
    Participant

    Sorry Britgirl, I did not know about the NoMachine logs at the time I had the error – so I did not capture them. If it happens to me again, I will be sure to save the logs.

    Thanks

Viewing 5 posts - 1 through 5 (of 5 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.