ERROR: NXPL::NXSelect

Forums / NoMachine for Linux / ERROR: NXPL::NXSelect

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #834
    Avatarsdepner
    Participant

    When I’m conecting to the Server I get this error:

    15:59:29:387.024 NXNODE-4.0.366[6562] ERROR: NXPL::NXSelect(25,7) exited with error ‘Interrupted system call’.
    15:59:29:389.244 NXNODE-4.0.366[6562] ERROR: NXPL::NXSelect(25,7) exited with error ‘Interrupted system call’.

    What’s going wrong?

    #855
    AvatarTor
    Contributor

    Is the session working and only that error is the problem?

    That error is just a signal interrupting the select, i.e. a perfectly normal condition. That’s not an error, really. We’ll remove that log, since it is clearly misleading.

    #859
    Avatarsdepner
    Participant

    No, the session is not working.
    The connection with the server was lost.

    Error is 134: Protocol error.

    #874
    Avatartitan
    Participant

    Please follow the instructions you get in “What to include” (see below), namely:

    – NoMachine product and version on local and remote machine (free version, Workstation, etc).
    – Whether the problem arises connecting to a physical or a virtual display.
    – Remote and local Windows/Mac/Linux version (Windows XP/7/8, OS X 10.x, Ubuntu xyz, Mint x.y, etc.).
    – If on Linux, desktop version (GNOME. KDE, whatever) on client and on server.

    That error is reported when the client is disconnected before getting past the session negotiation. It is likely a display problem. It would be useful if you could provide a tar of the server logs to the support.

    #947
    Avatarsdepner
    Participant

    Here the log files from the NX Server.

    Attachments:
    #962
    AvatarBritgirl
    Keymaster

    Hi,

    We still need to know:

    – NoMachine product and version on local and remote machine (free version, Workstation, etc).
    – Whether the problem arises connecting to a physical or a virtual display.
    – Remote and local Windows/Mac/Linux version (Windows XP/7/8, OS X 10.x, Ubuntu xyz, Mint x.y, etc.).
    – If on Linux, desktop version (GNOME. KDE, whatever) on client and on server.

    Thanks.

    #1012
    Avatarsdepner
    Participant

    Server RHEL: nomachine-enterprise-server-evaluation_4.0.366_2_x86_64

    Client Windows 7 64-Bit: nxclient-3.4.0-10 for Windows

    On the Linux RHEL Server: GNOME /usr/bin/gnome-terminal

    #1069
    AvatarBritgirl
    Keymaster

    Hi sdepner,

    This forum is for dealing with features and problems of version 4. This includes client and server and excludes compatibility problems with older versions, that are obviously managed by our support channel. I noticed you are using a client (3.4.0), which is 6 years old and for sure is not supported by version 4. What I suggest is that you first try to upgrade the client. If you experience the same problem with client 4 I’ll be glad to help you if you’ll open a new topic.

    #1305
    Avatarsdepner
    Participant

    Hi Britgirl,

    whats going wrong on om my NX Server?

    15:16:52:705.153 NXSERVER-4.0.366[2780] User ‘depner_s’ logged in from ‘172.25.50.37’.

    15:17:14:010.517 NXNODE-4.0.366[2853] ERROR: NXPL::NXSelect(24,7) exited with error ‘Interrupted system call’.

    15:17:14:011.818 NXNODE-4.0.366[2853] ERROR: NXPL::NXSelect(24,7) exited with error ‘Interrupted system call’.

    15:17:14:177.181 NXNODE-4.0.366[2853] ERROR: Error while starting PulseAudio server.

    15:17:20:720.122 NXNODE-4.0.366[2853] ERROR: Audio cleanup: cannot remove audio directory ‘/home/depner_s/.nx/C-emsvobtest04-

    1002-B842718FBFFB58216CD3506D1ACB7C0B/audio’: Directory not empty

    15:17:21:697.122 NXSERVER-4.0.366[2780] User ‘depner_s’ from ‘172.25.50.37’ logged out.

    #1309
    AvatarBritgirl
    Keymaster

    Did you update the client side software to version 4 as suggested? If so, we will need to see logs from both sides, plus the information that is listed in ‘What to include’ just below. Note that we’ve since release 4.0.369 and you can use the automatic updates to get the latest fixes.

    To update your installation:

    – Run the NoMachine GUI from your Programs menu.

    – Access the ‘Change server settings’ panel.

    – Click on the ‘Software updates’ button (last little icon on right).

    – Click ‘Check updates’.

    If the logs are too big, send them to issues[at]nomachine.com referencing your topic.

    Thanks.

    #1324
    Avatarsdepner
    Participant

    Hi Britgirl,

    My Installation is uptodate.

    The error occurs when I’m starting a gnome-terminal with “/usr/bin/gnome-terminal”.

     

    #1335
    AvatarBritgirl
    Keymaster

    Can you send the logs to issues[at]nomachine.com please? Make sure you provide the info I requested in my earlier post.

    Thanks.

    #1348
    Avatarsdepner
    Participant

    NoMachine product and version on local and remote machine (free version, Workstation, etc).

    Server: RHEL 6.4 nomachine-enterprise-server-evaluation_4.0.369_2_x86_64

    Client: Windows 7 64-Bit nomachine-enterprise-desktop-evaluation_4.0.369_2

    Whether the problem arises connecting to a physical or a virtual display.

    Physical desktop

    The error is reported when the client is disconnected before getting past the session negotiation. It is likely a display problem.

    It would be useful if you could provide a tar of the server logs to the support.

    see attached nxserver.tar.gz

    Attachments:
    #1467
    AvatarBritgirl
    Keymaster

    The logs don’t seem to contain any problem related to starting virtual sessions. Can you make sure you follow the steps here: https://www.nomachine.com/AR07K00677 in the section dedicated to Linux.

    You will need to:

    1) Set log level to debug as per instructions

    2) Reproduce the problem.

    3) Create a compressed archive of the NoMachine /var/log directory.

    4) Send the archive to NoMachine Support Team by e-mail .
    Don’t forget to include the client side logs as well. The userhome/.xsession-errors file will be useful to. Send everything to issues[at]nomachine.com.

Viewing 14 posts - 1 through 14 (of 14 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.