Errors during installation on Windows 11

Forums / NoMachine for Windows / Errors during installation on Windows 11

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #41449
    Rob27
    Participant

    Hello,

    I tried to install NoMachine client on a Lattidue 5520 Windows 11 but right after opening the installing exe I’m getting a lot errors with similar message “Cannot find an entry point for BN_is_Negative in library C:\Program Files\NoMachine\binn\libssh.dll”. The error itself is always the same the entrypoint and dll just differs(CRYPTO_zalloc at libnx.dll, ASYNC_WAIT_CTX_free at libssl.dll). If I just keep pressing OK the installation will finish but the service will not start at all.

    I’d appreciate any help, thank you.

    #41515
    Britgirl
    Keymaster

    Can you tell us how you downloaded the package and installed? i.e what browser did you use and how did you open the package? We’ve recently discovered an unusual behaviour in our packages when downloading via Firefox¬† that we are investigating that causes the above error.

    For the time-being, can you uninstall completely, re-download using a different browser, browse to the package using the Windows file explorer and install from there? Reboot again.

     

    #41624
    quux
    Participant

    Hello @Britgirl and all,

    I’ve got exactly the same problem (some error messages about missing entry points for this function or that) during installation. Although I’m on x64 Windows 10. Yes, I did use Firefox to download the installation .exe (nomachine_8.2.3_4_x64.exe). But, to be honest, your reply (that Firefox is the culprit) sounds dubious. I just re-downloaded the .exe with Google Chrome, and the downloaded file is exactly the same as what Firefox downloaded (I compared with fc /b) .

    So no, it does not look like Firefox has anything to do with this. 8.2.2.4_x64.exe is broken, please fix it or at least give a link to an older (“stable”) version.

    #41633
    Britgirl
    Keymaster

    Hi, I didn’t say that Firefox was the culprit. We are still investigating an unusual behaviour that we’ve reproduced when initiating the download of and installation of the 64-bit package from the FF browser window, even when the correct NoMachine installation procedure is followed.

    I just re-downloaded the .exe with Google Chrome, and the downloaded file is exactly the same

    The same file it is indeed, but I don’t know whether you initiated the reinstall of the package by browsing to the appropriate folder using Windows Explorer. So I’m not sure whether you mean the same error occurred.

    Either way, a workaround whilst we investigate you can download the 32-bit package and install that.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.