Exporting USB device with Wayland disabled ?

Forums / NoMachine for Linux / Exporting USB device with Wayland disabled ?

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #28630
    Avatarjeremy.fix
    Participant

    Hi,

    I’m working with :

    – a ubuntu 18.04 server, headless, running NoMachine 6.11.2-1

    – a ubuntu 18.04 client, running NoMachine 6.11.2-1

    I want to log on the server and share a USB device (Logitech Gamepad)

    – with the default settings, when I trigger the connection, I get a white screen, but nevertheless, I’m able to share the device. I did that by accessing the client connection parameters (on the page like corner and then connect USB device). I checked the USB device was correctly shared with a direct ssh connection, a lsusb on the remote server showed the device and a jstest /dev/input/js0 is working perfectly

    – by disabling wayland by uncommenting (#WaylandEnable=false) in /etc/gdm3/custom.conf as suggested on your forum I guess, I get a screen and I’m able to log in to the remote but I lose the ability to share the USB device.

    Do you have any clue on how I could solve this out ?

    Thank you !

    BTW, from my current experiments, NoMachine is waaaaaayyy faster than other softwares I experimented with (e.g. Remmina)

     

    Thank you for your product, it seems to work faster than what I e

    #28661
    Avatarjeremy.fix
    Participant

    Hi,

    A follow-up. Following the advice given here , on the remote server with Wayland enabled, I stopped gdm (sudo service gdm stop) and restarted nxserver (sudo /etc/NX/nxserver –restart). Then, on connection, the NoMachine client asked for creating its own framebuffer and I got the correct login screen (no more blank screen) and was able to forward the USB device.

    An additional bonus is that actually, when NoMachine is creating its own framebuffer, it is able to scale with the client window size, which was not the case with my previous setting using gdm.

    Jeremy.

    #28753
    AvatarDawid.G
    Participant

    Hi,

    NoMachine has a feature that automatically changes the server resolution to match the client.

    In order to turn it off, you may go to the “Display settings” in Menu Panel -> Display -> Change settings and uncheck the “Match the client resolution upon connecting” option.

    After reconnecting everything should work fine.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.