External access through Pfsense

Forums / General Discussions / External access through Pfsense

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #12042
    railstop
    Participant

    I am testing NoMachine and really liking it so far, the only problem I am running into is accessing from external sources. I am running pfsense 2.3.2, have setup port forwarding, tested NM and still get no external access. I’ve run through NM connection settings, ticked the gateway port box only to have it return  with “failed to map the port” error.  I have searched google and the forums here and it seems there is only one thread. I have exactly what one user suggested with no happy results.

    I’d love some help, and thanks in advance.

    #12059
    railstop
    Participant

    so after some more reading, the gateway access option only works if UPnP is up and funtional on the router, which I have disabled. I have tried to use port 4000 as the fording ports in pfsense with no luck still.

    #12062
    kroy
    Contributor

    We checked NoMachine on pfsense 2.3.2 and it works fine, so it looks like it’s wrong configuration problem.

    After login to pfsense GUI in menu navigate to STATUS / DASHBOARD. In “Interface” panel you can find external IP your network. Now navigate to FIREWALL / NAT and check rules. There should be correctly Interface (name should be the same as Interface with your external IP), Dest. Port (it’s the port which you should use in the NoMachine Player on the client side), NAT IP (if it’s for sure the same as on your machine with nxserver) and NAT Port (if you didn’t change NX Port – it should be 4000).

    After that server should be ready for use. In NoMachine Player create new connection with your external IP as Host, NX as Protocol and Dest.Port number as Port.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.