Extreme /var/log/gdm growth

Forums / NoMachine Cloud Server Products / Extreme /var/log/gdm growth

Tagged: 

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #12815
    Avatarswizzly
    Participant

    Hi,

    Since I installed the trial version of nomachine-cloud-server-5.1.54-2.x86_64 on a Red Hat Enterprise Linux 6.8 I experience an extreme growth in my /var/log/gdm directory, especially the files “:0.log*” are responsible for the problem. The log file can grow over 700MB+ and fill up the whole disk/partition. The same messages keep repeating several million times:

    AUDIT: Tue Nov  1 07:36:11 2016: 20140: client 6 connected from local host ( uid=13935 gid=13935 pid=11330 )
    Auth name: MIT-MAGIC-COOKIE-1 ID: 649
    AUDIT: Tue Nov  1 07:36:11 2016: 20140: client 6 disconnected

    On the client side I use V 5.1.26 Windows NoMachine client from a Windows 7 PC.

    Does anyone have some Idea?

    #12819
    Avatarswizzly
    Participant

    It seems the problem occurs only if a user logs in via “physical display”. Therefore, it can be a workaround to disable login via physical display. Edit the /usr/NX/etc/server.cfg file and add the following line: “PhysicalDesktopSharing 0”.

    It is a workaround, though it is not the real solution for the cause.

    #12827
    Avatarkroy
    Contributor

    We tried disabling PhysicalDesktopSharing in our labs, but did not prevent adding of the above-mentioned entry to :0.log. Are you able to reproduce problem again with enabled PhysicalDesktopSharing? If yes, could you turn on debug in the NoMachine configuration files, restart nxserver (sudo /usr/NX/bin/nxserver --restart), and if problem happens again collect logs and send to forum[at]nomachine[dot]com?

    Instructions about debug and collecting logs you can find there: https://www.nomachine.com/DT04M00076.

    If you are able to reproduce please send also output command ps -ef | grep [pid]. As “pid” use pid number from such big :0.log file (in mentioned entry you had that in first line and it was “11330”).

    To prevent storing large log files you can use logrotate utility (instructions for your RedHat 6 you can find there: https://access.redhat.com/solutions/1294). Example configuration:

    # cat /etc/logrotate.d/gdm
    /var/log/gdm/:0.log
    {
    daily
    rotate 2
    compress
    size 10m
    postrotate
    /bin/kill -HUP <code>cat /var/run/gdm.pid 2>/dev/null</code>  2> /dev/null || true
    endscript
    }
Viewing 3 posts - 1 through 3 (of 3 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.