Extremely sluggish behavior on Fedora 23

Forums / NoMachine for Linux / Extremely sluggish behavior on Fedora 23

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #10449
    jonnjonzzn
    Participant

    I’m using a fully up to date Fedora 23 with Gnome Shell on both my workstation at work and my laptop at home.  I am demoing the Linux Workstation edition 5.1.7 of NoMachine.  I did not see this behavior previously using the same configuration in Fedora 22.  I have also forced GDM to start using xorg and use xorg when logging into Gnome.  Any ideas, hints, tips?

    #10472
    graywolf
    Moderator

    Hello.

    I assume you have been using Gnome 3 in Fedora 22 like you are doing in Fedora 23. Is it correct?

    Depending on kind of session (physical or virtual display) things can change, so please let me know which is your case.

    I would check these things:

    • Run “top” and check CPU usage of nx* processes along with Xorg and Gnome.
    • Check the OpenGL renderer in use: in the remote session run “glxinfo | grep -i renderer”. Possible outcomes are “Software Rasterizer” and “llvmpipe”: the latter usually has better performance.

     

    #10473
    jonnjonzzn
    Participant

    Yes, Gnome 3 in F22 as well.

    These are both physical installations.

    The following information is for the “server” side, my workstation at work:

    [mcc77@mcc77 ~] $ glxinfo | grep -i rend

    direct rendering: Yes

    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,

    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,

    OpenGL renderer string: Gallium 0.4 on AMD CEDAR (DRM 2.43.0, LLVM 3.7.0)

    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,

    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil,

    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,

    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_fog_distance,

    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,

    lspci:

    01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series] (prog-if 00 [VGA controller])

    Subsystem: Dell Radeon HD 6350

    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+

    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-

    Latency: 0, Cache Line Size: 64 bytes

    Interrupt: pin A routed to IRQ 28

    Region 0: Memory at d0000000 (64-bit, prefetchable) [size=256M]

    Region 2: Memory at e1420000 (64-bit, non-prefetchable) [size=128K]

    Region 4: I/O ports at 3000 [size=256]

    Expansion ROM at e1400000 [disabled] [size=128K]

    Capabilities: <access denied>

    Kernel driver in use: radeon

    Kernel modules: radeon

    Thank you so much for your reply.

     

    #10504
    graywolf
    Moderator

    Could you tell me if you get this sluggish behavior when

    • you chose “Create a new virtual desktop”
    • you connected to share the physical display

    Did you look at CPU usage?

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.